LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 02-07-2005, 01:53 PM   #1
Firebar
Member
 
Registered: Feb 2005
Location: Southampton (UK)
Distribution: Debian, RHEL and SuSE
Posts: 69

Rep: Reputation: 15
IPW2200BG - Getting on a network...


Fedora Core 3

Hi everyone. I've installed all the appropriate drivers for this card, and after that I then did;

iwconfig eth1 essid xxxxx
iwconfig eth1 key xxxxx
dhclient eth1

Started up and got connected, no problem. Thing is, after the reboot I cant get on my wireless network anymore. The device seems to be ok, I have the wireless signal strength meter in the taskbar and that changes appropriately as I move further away from the router. If I try to activate the device after deactivating it, it cant get an IP. I know this isnt a problem with my router.

I've tried running dhclient eth1 again, and it sends out a DHCPREQUEST to 255.255.255.255. This isnt my subnet? does it matter? Mine is 255.255.255.0

So basically my card is picked up fine, but there is a problem with whats its doing to get an IP. Anyone have any ideas? I would be very grateful if someone can help me sort this.

My /etc/sysconfig/network-scripts/eth1-cfg is shown below;

IPVINIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=yes
GATEWAY=192.168.0.1
TYPE=Wireless
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=XXXXX
CHANNEL=1
MODE=Managed
RATE=11Mb/s

Last edited by Firebar; 02-07-2005 at 02:21 PM.
 
Old 02-07-2005, 02:48 PM   #2
Firebar
Member
 
Registered: Feb 2005
Location: Southampton (UK)
Distribution: Debian, RHEL and SuSE
Posts: 69

Original Poster
Rep: Reputation: 15
Think its ok now, disabling WEP sorted it. Strange, as the first time it was fine with WEP. I guess I'll just have to turn on wireless access control on my router.
 
Old 02-07-2005, 03:00 PM   #3
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
ipw2200bg slackware 10.2, kernel 2.6.13 howto! jstamcar Linux - Wireless Networking 6 10-09-2005 11:17 AM
setup IPW2200BG on FC4 problems takky Linux - Newbie 3 06-23-2005 10:00 PM
IPW2200BG "make" Error enigma128 Linux - Wireless Networking 2 04-17-2005 08:34 AM
RHEL4 AS trying to get ipw2200bg working ridge14 Linux - Laptop and Netbook 2 03-31-2005 04:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration