Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 04-08-2007, 04:57 PM   #1
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Rep: Reputation: 15
Question ipw2200 WPA-PSK

Yes I searched google, google/linux, and this forum, and I cannot find the answer...

I have just taken up WPA-PSK now that I've realized the little effort it takes to crack WEP. Unfortunately, Its not working for me on my laptop running Slackware (Backtrack2) with IPW2200.

# iwconfig eth0 key aaaa1bbbb
Error for wireless request "Set Encode" (8B2a) :

# iwconfig eth0 key restricted aaaa1bbbb
Error : unrecognised wireless request "aaaa1bbbb"

So I try wpa_supplicant...

# wpa_supplicant -i eth0 -D wext -c /etc/wpa_supplicant.conf

Line 9: failed to parse ssid '(my_ssid)'.
Line 9: failed to parse ssid '(my_ssid)'.
Line 14: Invalid PSK 'aaaa1bbbb'.
Line 14: failed to parse psk 'aaaa1bbbb'.
Line 15: WPA-PSK accepted for key management, but no PSK configured.
Line 15: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.

here is: /etc/wpa_supplicant.conf


pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40

hope this makes sense, any help is appreciated.
Old 04-08-2007, 05:52 PM   #2
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Original Poster
Rep: Reputation: 15

ok, problem #1 fixed which leads to problem #2...

first, in the wpa_supplicant.conf file

ssid="my_ssid" (put in QUOTES!)
psk="PSK" (again...quotes)

also, make sure you type your key is CORRECTLY entered (DUH!)

however, its not quite there...

# wpa_supplicant -i eth0 -D wext -c /etc/wpa_supplicant.conf

Trying to associate with AP_MAC_ADD (SSID='my_ssid' freq=2447 MHz)
Associated with AP_MAC_ADD
WPA: Key negotiation completed with AP_MAC_ADD [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to AP_MAC_ADD completed (auth) [id=0 id_str=]

at this point I do not get returned to the shell prompt and when I disconnect my wired port (eth1), no internet. Im close...any input appreciated.
Old 08-07-2007, 05:02 AM   #3
LQ Newbie
Registered: Aug 2007
Distribution: SuSE, Ubuntu, Debian, Backtrack2
Posts: 1

Rep: Reputation: 0
You do not get to return to the shell promt because wpa_supplicant is still running. Just open a new terminal and start dhcpcd for your adapter.

# dhcpcd eth0

You should now be connected =) Hope this helps.

p/s: To return to the shell promt after running wpa_supplicant, add -B option to run it in the background.

# wpa_supplicant -i eth0 -D wext -c /etc/wpa_supplicant.conf -B

Last edited by TzeHeng; 08-07-2007 at 05:03 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[ipw2200 & WPA] Need help to connect to WPA enabled router. Hyakutake Slackware 2 03-02-2007 10:58 AM
HP dv1000: using WPA-PSK with ipw2200 drivers in FC6 kalinatek Linux - Laptop and Netbook 2 02-02-2007 11:33 PM
wpa-psk, ipw2200 on Fedora Core 4 doesn't work RoyalGala Linux - Wireless Networking 3 01-25-2006 04:35 PM
how do I get my AP to use WPA-PSK ? lemon_hou Linux - Wireless Networking 1 12-28-2004 03:22 AM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 12:24 PM > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 06:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration