LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   IPW2200 Make error macro "create_workqueue" passed 2 arguments, but takes just 1 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/ipw2200-make-error-macro-create_workqueue-passed-2-arguments-but-takes-just-1-a-363062/)

jplev22 09-13-2005 04:52 PM

IPW2200 Make error macro "create_workqueue" passed 2 arguments, but takes just 1
 
My driver used to work fine until i patched suspend2, recompiled the kernel and compiled the hibernate package. After I rebooted from the kernel recompile, I got a modprobe ipw2200 error. I rebooted with my unpatched kernel but still got the same results... :confused: I tried to compile the module again but if I try to run make, I get the following:

make
mkdir -p /home/jp/ipw2200-1.0.6/tmp/.tmp_versions
cp /lib/modules/2.6.13/net/ieee80211/.tmp_versions/*.mod /home/jp/ipw2200-1.0.6/tmp/.tmp_versions
make -C /lib/modules/2.6.13/build M=/home/jp/ipw2200-1.0.6 MODVERDIR=/home/jp/ipw2200-1.0.6/tmp/.tmp_versions modules
make[1]: Entering directory `/usr/src/linux-2.6.13'
CC [M] /home/jp/ipw2200-1.0.6/ipw2200.o
/home/jp/ipw2200-1.0.6/ipw2200.c:10150:55: macro "create_workqueue" passed 2 arguments, but takes just 1
/home/jp/ipw2200-1.0.6/ipw2200.c: In function `ipw_setup_deferred_work':
/home/jp/ipw2200-1.0.6/ipw2200.c:10150: error: `create_workqueue' undeclared (first use in this function)
/home/jp/ipw2200-1.0.6/ipw2200.c:10150: error: (Each undeclared identifier is reported only once
/home/jp/ipw2200-1.0.6/ipw2200.c:10150: error: for each function it appears in.)make[2]: *** [/home/jp/ipw2200-1.0.6/ipw2200.o] Error 1
make[1]: *** [_module_/home/jp/ipw2200-1.0.6] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.13'
make: *** [modules] Error 2

I sure hope this is silly... Thanks for any input.

edit: I just remembered I also installed some dropline-gnome updates before the driver failed.

jplev22 09-14-2005 07:23 AM

I have just been sent a patched ipw2200.c from a friendly linuxer and it solved my problem. If anyone has the same problem, just pm me.

zborgerd 09-16-2005 12:34 PM

There is a known lockup problem with HAL and the ipw2200/2100 chips.

http://dropline-gnome.sourceforge.ne...ic.php?p=28946
http://dropline-gnome.sourceforge.ne...ic.php?p=28940

Have you experienced this at all? I noticed that you mentioned that you are using Dropline GNOME. Some folks have experienced this on Freerock GNOME as well (so it doesn't seem to be Dropline-specific), and found that disabling HAL corrects the lockups.

If your system doesn't lockup, perhaps you could share some details about your configuration? I'd like to help these folks find a solution to their lockup problem.


All times are GMT -5. The time now is 10:26 PM.