Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 04-26-2004, 04:50 AM   #1
LQ Newbie
Registered: Apr 2004
Posts: 14

Rep: Reputation: 0
intel pro/wireless 2100 -config questions + dhcp/dns


First of all I'm using Mandrake 10 Community + updates (so its basically MDK 10 official).

I'm using kernel 2.6.3-mdk8.

I've successfully (as far as I can tell) installed the ndiswrapper package version 0.7.

My question is, how do I turn on/off my network card?
(Is it always on or off by default?). In windows the software takes care of this for me....

Also in regard to DHCP, I'm trying to get connected on my uni. network (Monash university).
The standard way is to use DHCP to give you an address and in windows you use the obtain the DNS server automatically as well.

In linux how do I do this? Do I have to manually edit /etc/resolv.conf to add the nameservers?

Also, if I do ifup eth0 I get an error (don't have it with me now because I'm not at uni), I saw somewhere that I need to run dhclient eth0, to organise the DHCP address for that correct?


As far as I understand to get connected I need to load the NDISWRAPPER kernel module then type ifconfig wlan0 up (wlan0 is what its configured too).
Would I also need to do dhclient wlan0 (if I want to use the wireless card?).
Old 05-01-2004, 05:31 PM   #2
LQ Newbie
Registered: Apr 2004
Posts: 29

Rep: Reputation: 15
ok you do not say if you have installed ur .inf file from windows.. i have the card working on exactly the same kit this is what u do...
as root type
ndiswrapper -l
if you have successfully installed your windows inf file it will say blah present
if this is not the case do
ndiswrapper -i /path to inf file
and try again
if it is the case do
ndiswrapper -m
then modprobe ndiswrapper
then use iwconfig to set up to meet your settings
then type ifconfig wlan0 up
...once this is done go to control centre and network
click on new network connection - go to lan and the option wlan0 should appear if not try reboot.
once you go through this...finished the job after putting in the beginning it should give you an auto-ip option (DHCP) just check this in the modify network connections in the network control panel...once you have made all this sure then you can go to monitor connections to see if you get a complete connection...if this doesnt work at first always try a reboot and play around a little with settings
in my experience wep is tricky to get working...i have a non wep wirelessnetwork but i allow the wifi cards access on the router
hope this helps if not mail me


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2100 MiniPCI cald_nath Linux - Laptop and Netbook 10 12-25-2004 08:54 PM
connecting to the internet via wireless through Intel PRo/Wireless LAN 2100 3B Mini P k_wjss Linux - Newbie 1 09-28-2004 05:00 PM
intel PRO wireless 2100 centrino rgiggs Linux - Wireless Networking 23 07-29-2004 09:48 PM
Configuring a Intel Pro Wireless 2100 Korix Linux - Wireless Networking 2 05-20-2004 12:35 PM
Wireless intel PRO/Wireless 2100 802.11b WLAN gummimann Linux - Hardware 0 03-01-2004 04:20 PM > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 08:48 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration