-   Linux - Wireless Networking (
-   -   intel PRO wireless 2100 centrino (

rgiggs 04-19-2004 03:02 PM

intel PRO wireless 2100 centrino
has any one here successfully compiled a new kernel and got the centrino wireless stuff to work?
if so, could you please post your steps?
1 specific question: i believe i have to enable CONFIG_NET_RADIO during kernel compilation. now where is it in xconfig because the command line config is so many options, takes hours to go through.

fitzy85 04-19-2004 04:57 PM

hey mate...i have the same card in my acer aspire 2000..
i have used ndiswrapper to use the windows .inf file to generate drivers to work it...have managed to install it and everything and get a the config stage...plug in my wep code etc...i do get data being sent but as of yet have been unable to get a working connection..however i think that may be due to the config...something i have overlooked...i think the prob is with the type of wep key security... linux sets it as restricted and my router says automatic..if i manage to get it working i will let yaz kno ..
to get ndisloader go to sourceforge and search..installation is simple if u know the make command.

rgiggs 04-19-2004 05:03 PM

did u have 2 compile/patch ur kernel? i am using the ipw2100 @, and they say must have kernel 2.4.23+.

fitzy85 04-19-2004 05:06 PM

i have mandrake 10 and have 2.6.3 kernel....and did nothing having a looksee at ipw2100 now...
ok had a look mate...if you read the install document you will see you need to edit a few things in the kernel to get it working..i strongly suggest you give ndisloader a is a lot easier!!...hopefully it will work for you!! sure mines a simple config error

rgiggs 04-19-2004 06:51 PM

i thought ipw2100 is the only stuff that makes centrino on linux.
i'll try ndisloader.

Greg_courageous 04-20-2004 02:57 AM

Let me know if you get it to work, i have the same card = )

fitzy85 04-20-2004 04:21 PM

OK lads ive got the card working :)
i did it by installing ndiswrapper...see sourceforge for download.
once that was done i downloaded the windows driver and then did what ndiswrapper instructions will eventually say that the card if may have to try installing the driver a couple of times..(i used win xp driver)
once this is done...i followed the rest of the instructions so that the coding was set up it just needed to be configured..however i spent quite a few days trying to get it work..
heres how i eventually did it.. set it to DHCP in configure my computer.. (i have dhcp router) ..once that was done...i set to work on iwconfig...and spent hours moronically plugging in my wep no avail..kept on i set my wireless AP to disable wep..and left the iwconfig settings blank..and restarted laptop... lo and behold to my amazment it gave me the bootup line
WLAN0 ........................................[OK]
and the net was connected at boot :-p
hope that this gets people all happy wid wless afriad i havent got wep working..i think that it might only work on some router/card combinations...because of the security modes.. my AP only had one mode out of three that linux would let u set..and this didnt appear to work with the centrino it didnt work with windows..
let me kno if anyone gets wep working

joneSi 05-08-2004 10:49 AM

Where did you find a copy of the .inf file? I tried to extract the file in in wine, but I get an error. :S

~Steve Jones

fitzy85 05-09-2004 01:54 PM

i got a copy of the inf file from the driver you can download for windows...i have a dual boot machine you bet is 2 download the zip file from inte..and then extract the inf file out of that...if not i have an inf file...i can mail it 2 you

fastly 05-11-2004 07:12 AM

I had massive issues with a number of distros out there... until I loaded up Gentoo...

Running a 2.6.5 kernel I type:

FEATURE="-sandbox" emerge ipw2100

at the prompt when I'm connected to the net through eth0 and portage handles the rest...

Then to connect I make sure the modules are loaded first:

modprobe ipw2100


ifconfig eth1 up

Scan networks using

iwlist scan

Then connect to a network using

iwconfig eth1 essid blah

Sometimes I may have to

dhcpd eth1

But it runs like a dream and far easier to get working than with other distros I have tried (SuSE, redhat etc)...


fastly 05-11-2004 07:14 AM


FEATURES="-sandbox" not FEATURE="-sandbox"

Oh and don't ask me what a sandbox is... I still think it's a box full of sand. Someone on IRC told me this was necessary (it doesn't work without it)..

joneSi 05-11-2004 05:40 PM

OK, I can get ndiswrapper to load up, and it scans the 'airwaves' but it makes my keyboard act funny. I can't type stuff in or it makes one letter repeat. And its never the same one...makes getting the driver uninstalled not so easy.

Thanks for any input....


fastly 05-13-2004 04:21 PM

I've got some advice... don't ignore my last post - it works.

joneSi 05-13-2004 09:09 PM

Hmmmm, it makes my keboard do things like this.

ndiswrrrrrrrrrrrrraaaaaaaaaaaaaaaappppppppppppppper and so its IMPOSSIBLE to type. Anything I'm missing with the sandbox...where do I put that. Just in a term? Lemme kno :)


geomatt 05-16-2004 09:17 AM

I've been reading this thread and trying to figure out how to get the centrino 2100 wireless thang working and wanted to report on my success - WEP and all.
I'm running slack 9.1 on an IBM r40 laptop.

Here's what I did:
1. downloaded and ran swaret (for the non-slack: slackware's package upgrade tool) to upgrade the kernel from version 2.4.22 to version 2.4.26.
2. installed the hostap drivers (needed for WEP support)
3. installed the ipw2100 driver
4. put a copy of the latest firmware into the appropriate directory
(the hostap drivers and firmware is all available at the ipw2100 site, and ipw2100 INSTALL file contains instructions for installing, where to put the firmware, etc.)
5. edited /etc/rc.d/rc.inet1.conf so that my ip address is assigned by rc.inet1 to eth1 (the centrino device) and not eth0 (a built in ethernet card)
6. wrote a script called by /etc/rc.d/rc.local (run at boot time) that loads the ipw2100 driver, brings up eth1,
configures wireless parameters like essid, and the WEP key I use.
7. rebooted and presto it works WEP and all.

Some details would need to be adjusted if you aren't running slackware and they probably also show that I'm an almost complete newbie. Maybe there's some unnecesary stuff in there? Maybe there's a better less hackish way to do it?

Good luck all!

All times are GMT -5. The time now is 04:11 PM.