-   Linux - Wireless Networking (
-   -   Intel Pro 2915 in FC3 (

adymroxx 03-23-2005 11:38 PM

Intel Pro 2915 in FC3
Hello all. I just bought a Dell Inspiron 6000 and loaded Fedora Core 3 first thing. It didn't pick up on my Intel Pro 2915 802.11 a/b/g integrated wireless card out of the box, but after I downloaded all the Up2Date patches it recognized it with Kudzu on the next boot. However, it cannot determine ip information from my access point. I've used an old Windows laptop with WinXP on it in the same location as my Dell and it works fine with my access point. I've tried statically setting the IP of my Dell with no success. It is still not finding the card's MAC address nor that of my access point. After setting the ESSID of eth1 (the integrated wifi interface), I entered this:

[root@localhost ~]# ifup eth1
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not supported.

Determining IP information for eth1... failed; no link present. Check cable?

I'm completely stumped and have spent the better part of the day looking for a solution. Hopefully someone can set me down the right path. Sorry for the wordy description - this is my first thread post for a linux problem.
Thanks again!

WMD 03-24-2005 12:19 AM

Run the "Internet Connection Wizard" (I assume Red Hat still includes it) and select "wireless." Configure it from there. Anything?

adymroxx 03-24-2005 02:45 PM

It still doesn't work. Spent a f ew hours today trying different configurations, uninstalling and reinstalling the driver and FC3 after I messed with the configuration too much. It will activate on boot and accept the ip I've given it of, but it isn't really on my home network. It can't ping my access point of or any of the other workstations I have. It's still not showing anything for the wifi card's MAC, just 00:00:00:00:00:00, which, if I had to guess, is the main problem since it's the default configuration for eth1 is to bind to that MAC.

So, is there a way for me to find its MAC and bind it to the card and get everything to work? Maybe another distro that actually accepts my card?? I'm willing to try anything right now!

adymroxx 03-25-2005 11:18 PM

So I found the MAC after dual-booting into Windows XP and running an ipconfig -all and then hopped back into FC3 >Applications >System Settings >Network, Properties of eth1 and attempted to bind its MAC. However, this is apparently not the MAC it was expecting, or so claims the error message that appeared. I unchecked the "bind to" (which is the default setting for my working eth0 landline) and saved the config. Now I can't bring up eth1 because the device doesn't seem to be present. This explains why my MAC is NULL but I'm completely at a loss as to how to fix that. Any help would be greatly appreciated. Thank you again

adymroxx 03-31-2005 04:36 PM

After a week and countless hours, I finally got my card to work. I reinstalled FC3 with ALL packages (not sure if this is necessary but I'm scared to try it otherwise now) and did NOT update my kernel. Although the Up2Date upgrae to 2.6.770 automatically loads the IPW2200 driver, it rendered my card useless. Rather, I visited downloaded and loaded the driver/firmware/hot plugs myself and now it works great. I tried upgrading to kernel 2.6.770 after that and it does not work with the 2915 card so I reverted back to kernel 2.6.667 and am happy.

All times are GMT -5. The time now is 08:27 PM.