LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Installing internal 3G Card (https://www.linuxquestions.org/questions/linux-wireless-networking-41/installing-internal-3g-card-616384/)

Emerson 02-14-2008 04:08 PM

Stock kernels often have compressed config file compiled in, try /proc/config.gz.

CrownAmbassador 02-15-2008 02:24 PM

I don't have anything there. Do have a config file in /boot though, but I don't know how to edit it. I actually thought I posted a reply here earlier, but aparently not. According to the website I got the kernel from, ppp is in the kernel but it looks to me that it is in as a module.
Code:

#
# Common config options automatically generated by splitconfig.pl
#
CONFIG_PPDEV=m
CONFIG_PPP=m
CONFIG_PPPOE=m
CONFIG_PPPOL2TP=m
CONFIG_PPP_ASYNC=m
CONFIG_PPP_BSDCOMP=m
CONFIG_PPP_DEFLATE=m
CONFIG_PPP_FILTER=y
CONFIG_PPP_MPPE=m
CONFIG_PPP_MULTILINK=y
CONFIG_PPP_SYNC_TTY=m


Emerson 02-15-2008 02:46 PM

find /lib/modules -name ppp*

Does it find something? The configuration file in /boot may belong to your previous kernel.

CrownAmbassador 02-15-2008 02:54 PM

No, the config file is config-2.6.24-7-generic.

This is what is find with that command, but I'm running my old kernel at the moment in order to connect to the internet (and not use Windows). Won't make a differents to the results right??

Code:

crownambassador@Vista:~$ find /lib/modules -name ppp*
/lib/modules/2.6.24.2/kernel/net/atm/pppoatm.ko
/lib/modules/2.6.24.2/kernel/drivers/net/ppp_deflate.ko
/lib/modules/2.6.24.2/kernel/drivers/net/ppp_mppe.ko
/lib/modules/2.6.24.2/kernel/drivers/net/ppp_synctty.ko
/lib/modules/2.6.24.2/kernel/drivers/net/pppox.ko
/lib/modules/2.6.24.2/kernel/drivers/net/ppp_async.ko
/lib/modules/2.6.24.2/kernel/drivers/net/ppp_generic.ko
/lib/modules/2.6.24.2/kernel/drivers/net/pppoe.ko
/lib/modules/2.6.24-7-generic/kernel/net/atm/pppoatm.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/ppp_deflate.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/ppp_mppe.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/ppp_synctty.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/pppox.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/ppp_async.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/pppol2tp.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/ppp_generic.ko
/lib/modules/2.6.24-7-generic/kernel/drivers/net/pppoe.ko
/lib/modules/2.6.22-14-generic/kernel/net/atm/pppoatm.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/ppp_deflate.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/ppp_mppe.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/ppp_synctty.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/pppox.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/ppp_async.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/ppp_generic.ko
/lib/modules/2.6.22-14-generic/kernel/drivers/net/pppoe.ko
/lib/modules/2.6.24.2-custom/kernel/net/atm/pppoatm.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/ppp_deflate.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/ppp_mppe.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/ppp_synctty.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/pppox.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/ppp_async.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/ppp_generic.ko
/lib/modules/2.6.24.2-custom/kernel/drivers/net/pppoe.ko
/lib/modules/2.6.24.1/kernel/net/atm/pppoatm.ko
/lib/modules/2.6.24.1/kernel/drivers/net/ppp_deflate.ko
/lib/modules/2.6.24.1/kernel/drivers/net/ppp_mppe.ko
/lib/modules/2.6.24.1/kernel/drivers/net/ppp_synctty.ko
/lib/modules/2.6.24.1/kernel/drivers/net/pppox.ko
/lib/modules/2.6.24.1/kernel/drivers/net/ppp_async.ko
/lib/modules/2.6.24.1/kernel/drivers/net/ppp_generic.ko
/lib/modules/2.6.24.1/kernel/drivers/net/pppoe.ko


CrownAmbassador 02-16-2008 08:26 AM

Advice
 
The kernel I installed is the stock kernel for the next release of Ubuntu, namely Hardy, scheduled to be released in April, but it is still under development. So I guess I have two options. To keep this kernel and get the 3G modems to work, or figure out how to install the 2.6.24 kernel. What do you guys think will be the best?

CrownAmbassador 02-19-2008 05:40 AM

Have I been forsaken?

When I run tail -f /var/log/messages and flip the 3G switch this is what I get:

Code:

Feb 19 12:38:12 Vista kernel: [ 2625.306466] atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
Feb 19 12:38:12 Vista kernel: [ 2625.306477] atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
Feb 19 12:38:13 Vista kernel: [ 2625.792742] usb 1-2: new full speed USB device using uhci_hcd and address 4
Feb 19 12:38:13 Vista kernel: [ 2626.019407] usb 1-2: configuration #1 chosen from 1 choice

I've been able to temporarily connect my USB modem via wvdial untill I can get the Vodafone program to work. So now I want to concentrate on the embedded card. I think if we can figure out its location I'll be able to configure wvdial to use it.

Emerson 02-19-2008 08:29 AM

We know the location, the switch obviously does not operate this device, at least not in hardware level. Do not connect the external modem or anything else external, boot up and look at lsmod output. Is usbserial loaded? If it is loaded and udev does not create ttyUSB devices you may need to create them manually with mknod.

CrownAmbassador 02-19-2008 09:07 AM

Hi Emerson!

I actually got it sorted out. I downloaded and installed the latest Vodafone app version. When it starts up it gives you a option to add devices. I played around a bit and added the modem as /dev/ttyUSB0 (in both lines it gives you, can't remember what the lines are called). After that it said "initial setup" for so long that I canceled it. But when I went in again, it worked! I figured out that the switch disactivated the receiving part of the card, but the computer can still see the card.

So now that is sorted and I want to thank you and comprookie and everyone else so much for all the help! One always learn more when you struggle!

I would still have liked to sort out the USB modem too, but I don't see a option in the vodafone app to add a device. So I think I'll rather leave it as is. I have been able to figure out how to use it with wvdial.

Just for interest sake: When I start the app with the USB modem attached is says:

"Device setup not complete

Your device "Huawei E270" is not properly registered with the kernel. Vodafone Mobile Connect Card driver for Linux needs at least two serial ports to communicate with your Huawei E270. The program includes a set of udev rules plus some binaries that make sure that your device is always recognised properly. If you've installed from source, then make sure to copy the relevant files in the contrib dir"

If I get a way to add devices via the app, I'll try again, but feel free to share your thoughts on the above message.

Take care,
Conrad

Emerson 02-19-2008 09:21 AM

You are welcome! :D

Please contact USB-ID database maintainer so your device can be added to the list.
http://www.linux-usb.org/usb.ids

Unfortunately I have not seen this Vodafone app, obviously it comes with udev rules which have to be installed. Is there anything in the documentation about how to install them? You may copy them manually into /etc/udev/rules.d/.

CrownAmbassador 02-19-2008 09:28 AM

There was two files for the the modem, namely 99-huawei-e220.rules and huaweiAktBbo.c that I copied there, but that didn't change anything.

I'll contact USB-ID right now.


All times are GMT -5. The time now is 11:40 PM.