LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   installing bc4319 wireless chipset on my dell inspiron b130 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/installing-bc4319-wireless-chipset-on-my-dell-inspiron-b130-493458/)

mkalkere 10-18-2006 07:09 AM

installing bc4319 wireless chipset on my dell inspiron b130
 
hi there.... i am new to fedora5 and i am no able to configure my wireless card which has a chipset of bc4319... i tried many things posted but nothing is woring... can any one help me plz...but it has detected correctly my wireless card as"Brodcom Corporation Dell Wireless 1470 DualBand Wireless"

144419855310001 10-25-2006 10:16 AM

Quote:

I tried many things posted but nothing is woring
It would be helpful if you could give details of exactly what you have tried! ndiswrapper/etc?

I think bcm43xx-fwcutter might be what you need here (?)

Although linux has recognised that you have this card, distro's don't tend to come with the actual drivers for wireless cards, so you have to use the windows driver. Mostly. Support for broadcom cards in the kernel is also fairly recent.

First install the bcm43xx-fwcutter from Fedora extras / elsewhere, as appropriate for your distro. Now search your windows partition for bcmwl5.sys and bcmwl5.inf. Copy them into some empty directory on your linux partition.

Then within this directory do this in terminal:
Quote:

bcm43xx-fwcutter bcmwl5.sys
(Note: this above is on the ".sys" file, not the ".inf" file)

Now copy everything within the directory you are in to /lib/firmware (you'll need to be root).

...and delete and reinstall the wireless card in Networkmanager (system-config-network). Now in terminal as root, do:
Quote:

/sbin/service networking stop
/sbin/service networking start
That should / might work.

mkalkere 10-30-2006 09:44 AM

installing bc4391 wireless chipset
 
hay thanks a lot .... i managed to install and make my wireless card work.... what ever u sent was very helpful and it worked... thanks a lot.... thx...

mkalkere 11-19-2006 12:33 PM

hi help me once again plz........
 
i have installed fedora 6.... and whwt ever u said for fedora 5 is now not working for fedora 6.....plz

144419855310001 11-20-2006 07:03 PM

Hmmm... sorry, I'm still using Core 5, so I don't know why!

Hopefully some other kind person will post something to help.
However, it would be good if you could details of at what stage things are going wrong. Could you be a little more specific?
Also, do you get any error messages, etc.?

Otherwise, you may have to google it
(If you find anything, you should post the answer in this thread for anyone else having a problem).

Apologies.

mkalkere 11-22-2006 11:01 AM

hay hi this is the following error what i get....and thanks yaar for u'r reply u respond to my messages quickly....

[root@localhost untitled folder]# bcm43xx-fwcutter bcmwl5.inf
Sorry, the input file is either wrong or not supported by bcm43xx-fwcutter.
This file has an unknown MD5sum 30d785d5f4daec4a1cf15ed867357a82.

144419855310001 11-23-2006 10:47 AM

Perhaps you should try this:
Quote:

bcm43xx-fwcutter bcmwl5.sys
instead of this:
Quote:

bcm43xx-fwcutter bcmwl5.inf
What happens now?

144419855310001 01-16-2007 06:16 AM

Found the answer. (*as well* as the post above)

On FC6 (just upgraded), if I want to activate my wireless card, I have to do (as root):

Quote:

/sbin/dhclient eth1
That's it. After that, my wireless light comes on and everything's fine.
Try that after everything else above.


All times are GMT -5. The time now is 03:22 AM.