-   Linux - Wireless Networking (
-   -   I cannot connect to WEP-protected wireless network (

niklasfischer 12-11-2006 04:00 AM

I cannot connect to WEP-protected wireless network

I'm trying to connect to my WEP-protected Wireless Network at home.

64-bits key hexadecimal using first of four keys generated at the router.

Wirless Network Card
D-Link DWL-510 (RTL8180)

My network card is detected and running and when I use the Network tool in System->Administration I can set my eeid and password and everything seems to work but Idon't get an IP-address and the card cannot find any AP.

I have tryed NetworkManager but it dosen't show my wireless connection and when I doubleclick the nm-icon nothings happen (some forums tells me to do so and then choose add connection).

I then tried WIFI-radar and it shows the wireless connection but I can't do anything with it.

I then tried another graphical tool that I don't remember the nam for but that tool shows me the wireless connection and it shows me the signal strength which is good but I still don't get an IP-address and therefore I cannot connect to Internet for example.

I'm stuck and I cannot find any solution to my problem at any forum. From what I can tell I don't have to use any wrapper for windows driver or wap_Supplicant with my settings and hardare...

For whats it worth I can use the card perfectly in Windows so there is no router failure or other hardware failure...

Can anybody help me?

kassle 12-11-2006 04:16 AM

iwlist [eth?/ath?] scanning

check are your AP is detected ?

configure the wi-fi with the following command

iwconfig [eth?/ath?] essid [your_essid] key [essid_key]

then do

dhclient [eth?/ath?]

to get IP from AP.

*eth?/ath? is your wi-fi device name

All times are GMT -5. The time now is 08:21 PM.