-   Linux - Wireless Networking (
-   -   HOWTO: Bcm43xx Broadcom Drivers! (

secretservgy 07-11-2006 12:39 PM

HOWTO: Bcm43xx Broadcom Drivers!
This is a how to on how to get the stubborn infamous Broadcom 43xx wireless cards working:

First download the drivers from my website:

1) Blacklist bcm43xx driver
Open a Terminal window
Type "sudo gedit /etc/modprobe.d/blacklist"
At the bottom add the lines
# get rid of the default kernel drivers
blacklist bcm43xx

2) Make sure network interfaces file is correct
Type "sudo gedit /etc/network/interfaces"
Remove all comments ('#') that you see so that all devices arehandled by the default network manager.
I would reboot here and make sure the wireless light goes out

3) Install ndiswrapper
Put in Ubuntu CD. Open Synaptic Package Manager (ClickSystem -> Administration -> Synaptic Package Manager),search for ndiswrapper-utils, and install it.You could also type "sudo apt-get install ndiswrapper-utils (IF you are not using ubuntu then make sure you have ndiswrapper-utils somhow installed)

4) Conigure ndiswrapper
Open terminal and navigate the folder where your drivers are."cd Desktop/bcm43xx"
Type "sudo ndiswrapper -i oem3.inf"Then type "sudo ndiswrapper -m"
Type "sudo gedit /etc/modprobe.d/ndiswrapper"Change the one line in that file to read "alias eth1 ndiswrapper"

Now you should reboot so all the drivers load.

Once you reboot the wireless light on your laptop should be lit. If it worked, you should be able to click the Network Manager icon in the top right. It will probably show a disconnected ennection becuase the computer is not plugged in.
Left click it and select eth1 from the drop down menu.
Click Configure
Click Wireless Connection, then Properties. Here just enter your network information. If you're using an unprotected network you should only have to type yout SSID.

Click OK and you should now be connected! If a green signal meter and connected network icon appear in the upper right you'll know it worked.

Hangdog42 07-11-2006 02:16 PM

I think the title for this thread is extremely misleading. It is really about how to disable bcm43xx by putting it on the blacklist, not how to get the driver working.

secretservgy 07-11-2006 04:02 PM

Well the problem with the 43xx cards is that thier firmware is not supported by certain distros (ubuntu for me) in which thats the problem... This how to shows how to use ndiswrapper with the drivers from windows and making it work. No matter if its blacklist or works for me.

secretservgy 07-11-2006 04:06 PM

I'm sorry about the title, i'm not sure how to change it , but if you can give me a suggestion and tell me how to change it then i would be glad.

Hangdog42 07-11-2006 04:42 PM


Originally Posted by secretservgy
Well the problem with the 43xx cards is that thier firmware is not supported by certain distros (ubuntu for me) in which thats the problem...

Sorry, but that isn't right. Distros may not include firmware, but I've never seen anything to suggest that certain firmware won't work on certain distros. If you have, please provide a link to the source.

You may need to create your own firmware with fwcutter and the Windows driver, but that is pretty easy. You just compile fwcutter, then run fwcutter WindowsDriverfilename.sys then run make installfw.

secretservgy 07-11-2006 04:56 PM

sir, with all due respect, this works for me, thats why i posted it, to help others. And yes, i was wrong, firmware isnot included with Ubuntu for liscening reason for the Broadom card.

Hangdog42 07-11-2006 06:38 PM

Honest, I'm not trying to belittle your contributions. I certainly encourage people posting what works for them and I hope you will continue to do so. It was not my intention to offend you and you have my apologies if I did so.

The problem with the bcm43xx driver is that the documentation and help are close to non-existant, so statements like "the firmware isn't supported by certain distros" can be very damaging. There is literally nothing out there to contradict these kinds of statements, so those who do have experience with this driver need to try and keep what little is out there as accurate as possible.

secretservgy 07-11-2006 06:42 PM

ok, its just when i installed ubuntu i remember when unzipped kernal or what not it said it couldnt find or load the broadcom firmware.

secretservgy 07-11-2006 06:44 PM

i guess i should be more accurate as to what it worked on. So i used this on a machine (laptop, amd64 3700+ 2.4ghz,broadcom 4318 AirForce54g card) running Ubuntu Dapper Drake 6.06 32bit.

slso03 09-24-2006 05:51 AM

This just worked for me after many hours of trouble finding a solution...thanks a lot!

klrtmto 11-08-2006 01:36 AM

Thank you, worked for me as well!
For anyone's general information, I'm running a (3 day old) compaq v5305wm ($400 wal mart special) laptop.

AMD sempron 3300+ (2.0Ghz) CPU
Broadcom 4318 wireless mini pci internal card.

I'm also running MEPIS 6.0 (which is Ubuntu based) & WinXP Media Center edition dual boot. I downloaded the drivers & followed the instructions. Instant success! Thank you very much.


ultimatenoob 11-13-2006 04:13 PM

Just tried this after reinstalling Kubuntu (because of some grub problems) and it did not work. Should changes be made to /etc/network/interfaces to include eth1? I changed a couple of things, but with no luck. I think i'm going to be installing Gentoo though, because grub on my current install fails every month or so :scratch:

klrtmto 11-14-2006 08:51 AM

changes to eth1
Well these instructions tell you to do "ndiswrapper -m". This adds a line for "wlan0" into /etc/modprobe.d/ndiswrapper. Then the instructions tell you to edit that line which was added by the command "ndiswrapper -m", such that it referneces "eth1". On my machine, /etc/modprobe.d/ndiswrapper was a one line file, and it referenced wlan0, which was where I like to see the wireless device anyway, so i left it alone. I did not need to edit /etc/modprobe.d/ndiswrapper. My wireless device shows up as "wlan0", right where ndiswrapper put it.

Also a quick note. The drivers which are available at the compaq website for my computer did NOT work using this procedure. I had to download the ones in the instructions above.

Hope that helps.


crasslogic 12-23-2006 03:40 PM

Anyone get this to work for Slackware?
I'm running a fresh install of Slackware 11.0 on the same Wal-Mart special that klrtmto is.

I ran lsmod and modprobe to see if bcm43xx existed for me, which it doesn't, but I followed Step 1 here anyway.

Next, in step two, I don't have a /etc/network/interfaces ,
I do have a /etc/networks which is a file, and inside it there is only two lines that say
And where it says the light should go out, it's never been on since I removed the stock XP install and installed Linux.

I installed ndiswrapper with no problems that I can tell. I tried to build the 1.32 package from the sourceforge site but that failed, with some build error, so I downloaded a slackpack that was version 1.10 I believe. I then issued the commands listed in step 4, except there was no /etc/modprobe.d/ndiswrapper file, so I created one with the alias line. Of course, no success here. Any ideas? I've been working on getting this damn wireless garbage to work for I don't know how many days now.
Any suggestions or links would be very sincerely appreciated.

Thanks all.

I'm aware of the site, but it's been down for some time now it seems :(

Hangdog42 12-23-2006 04:26 PM


Next, in step two, I don't have a /etc/network/interfaces
Slackware works a bit differently. Most of the config stuff is in /etc/rc.d/.

I tried to build the 1.32 package from the sourceforge site but that failed, with some build error, so I downloaded a slackpack that was version 1.10 I believe.
This is likely not going to work. You really need to build ndiswrapper against your kernel. If you post the errors your getting, we can probably sort it out.

All times are GMT -5. The time now is 10:22 AM.