-   Linux - Wireless Networking (
-   -   How to correct "yum" and "modprobe" when using ndiswrapper? (

BootLaptop 07-15-2007 06:40 PM

How to correct "yum" and "modprobe" when using ndiswrapper?
I am trying to get access the internet using Enterprise Unbreakable Linux. I encountered 2 warinigs and one FATAL error while installing ndiswrapper. As you can see the driver did install, however I got an error when I tried to use "yum" and "modprobe":

I downloaded ndiswrappers version 1.47.
I typed "su -c 'yum install kmod-ndiswrapper'"
the response was:
"setting up install process"
"setting up repositories"
however the error message was:
"cannot find a valid baseurl for repo: update"
Therefore I didn't use yum and proceeded as follows
1)created a directed named "ndiswrapper_drivers"
2)tar -zxvf ndiswrapper-1.47.tar.gz
3)make uninstall
4)make distclean
6)make install
NOTE: this gave two warnings:
a)'task_nice': (/ndiswrapper_drivers/ndiswrapper-1.47/ndiswrapper.ko) undefined!
b)this kernel seems to use 4k stack size option(CONFIG_4KSTACKS): many Windows dirver will not work with the option enabled . Disable CONFIG_4KSTACKS option recompile and install kernel
NOTE:Windows config file format changed since 1.5 you must reinstall windows driver if they wre installed before
7)ndiswrapper -i bcmwl5.inf
(driver now installed)
8)ndiswrapper -i bcmwl5.sys
(driver already installed)
9)ndiswrapper -l
(driver now present)
10)demod -a
11)modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.9-; unknown symbol in module or unknown parameter.

The error file ndiswrapper.0 file in step 11 seems to be the same error file in ndiswrapper.k0 file after step 6.

How can I get "yum" to work and "modprobe" to work with respect to the 2 warinings and the fatal error?

Junior Hacker 07-15-2007 07:52 PM


Originally Posted by BootLaptop
How can I get "yum" to work and "modprobe" to work with respect to the 2 warinings and the fatal error?

Yum needs an internet connection for it to work as it looks for packages at the mirrors. But if you were to mention which distribution you're using, it would be easier to recommend which package to install, as most all distributions have ndiswrapper in pre-compiled binaries. Because you tried installing a package ending in .tar.gz, means you are installing a source package, yum installs pre-compiled binaries for your distribution, not source code.
Here's one way of get it done:
Go here and put "ndiswrapper" in the search field and click search, there are 11 pages of results, find the package for your distribution and click on it, the next page will give download links and information for the package including any dependencies it may require under "requires". Install it with rpm install command like so:

rpm -ivh packagename.rpm
Now, it may be worth googling on how to use this as I understand you need Windows drivers with ndiswrapper, I never used it so know not what to do, but you're better off using pre-compiled distribution specific binaries.
It appears you're using a xen kernel or something, and an unstable one at that, or you have the wrong source installed. You should give relative information in your posts, like what distribution?, what kernel?, what you are trying to get drivers for?.

GregLee 07-15-2007 08:14 PM

I wouldn't worry about the "b)" warning during the make, but this warning: "a)'task_nice': (/ndiswrapper_drivers/ndiswrapper-1.47/ndiswrapper.ko) undefined!" is bad news. There's no point in going any further.

I think you should have said "ndiswrapper -m" before "depmod -a".

All times are GMT -5. The time now is 07:03 AM.