LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 12-26-2003, 10:09 PM   #1
jxbrown
LQ Newbie
 
Registered: Dec 2003
Posts: 14

Rep: Reputation: 0
Talking How I got my wireless to work/SuSE 9.0


This is a bit kludgy, but at least it's working. Originally I loaded SuSE 9.0, configured the wireless card (in my case a Siemens SpeedStream 1024) with YaST, downloaded the pcmcia package (although it's not a PCMCIA card), and added myself to the "www" group in the /etc/group file so that I would have privelege. Well that worked great until I rebooted, but I could never get it to work again. My guess is that the problem is due to the order that everything is booted up and I just got lucky the first time. I never did get SuSE 8.1 to work.

What I did to get it working again:

1) Used YaST to configure wlan0, but not eth0 since my ethernet card is not being used and it was grabbing control of DHCP. You can also comment out the "alias eth0" line in /etc/modules.conf. YaST added the line "alias wlan0 hostap_pci" to modules.conf and should add the appropriate driver to yours. I could also have set channel and ESSID through YaST, but didn't because I get intermittent errors at boot up.

2) Although the SuSE literature said that I didn't need to change resolv.conf, I did. It looks like this:
domain local
localhost 127.0.0.1
nameserver 192.168.0.1

3) I configured the default gateway through YaST -> network services. The /etc/sysconfig/network/routes file looks like this:
default 10.0.0.0 - -

4) The configuration file /etc/sysconfig/network/ifcfg-wlan0 looks like this:
BOOTPROTO='dhcp'
WIRELESS='yes'
STARTMODE='onboot'
UNIQUE='t2XO.Rvt8MuqLWB9'
MODE='Managed'
ESSID='default'
CHANNEL='6'
DHCLIENT_MODIFY_RESOLV_CONF='yes'

Note that my router's ESSID is "default" and its channel is set to "6". However, if I check ifconfig after boot up it doesn't reflect these values. I have to manually change mode to "Managed" before I can set the ESSID and channel using iwconfig. The literature for SuSE 8.1 said that the last variable had to be set to "yes", but 9.0 literature didn't tell me that however, that proved to be the last piece of the puzzle. YaST set WIRELESS_MODE, WIRELESS_ESSID, and WIRELESS_CHANNEL instead of MODE, ESSID, and CHANNEL, however those were giving me errors at boot up...sometimes. ifup is looking for the WIRELESS_ versions, I think so they don't get set with this file, but I got tired of screwing around with it! After I post this, I will comment them out and reboot and see if that works.

5) I left the files /etc/sysconfig/network/config and /etc/sysconfig/network/dhcp unmodified.

6) I added my user name to the "www" line in /etc/group:
www:x:8:julie
(actually I added my name to all of the lines in the file. It's my computer damn it)

7) To get the whole thing going I run the following script:

#! /bin/bash

ifdown wlan0
iwconfig wlan0 mode managed
iwconfig wlan0 essid default
iwconfig wlan0 channel 6
ifup wlan0 -o dhcp

/etc/init.d/network restart


After the script executes, it takes a few seconds for the network connection to be established. If I were cool, I would put a little sleep time at the end of the script. Once it is going the /sbin/route -n command shows the following:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0


I hope this helps someone.
 
Old 12-26-2003, 10:34 PM   #2
jxbrown
LQ Newbie
 
Registered: Dec 2003
Posts: 14

Original Poster
Rep: Reputation: 0
I commented out the ESSID, CHANNEL, and MODE=Managed lines in ifcfg-wlan0 and rebooted. That did not work even though I'm setting those variables manually. I suspect that their absence goofs up the ifup-wireless script.

After uncommenting those line and running my little script, I didn't get an IP address or a routing table until the second time I ran the script. I think there is still a timing problem. I've had that happen before, but a second restart fixes the problem.

Anyway, the bottom line is that the above method, while a little on the inelegant side, is functional. I suppose that it will be a good learning exercise to make this work "right", but not tonight....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A wireless cards that work with SuSE 9.2 RHLinuxGUY SUSE / openSUSE 3 10-07-2005 02:13 PM
Which PCI wireless cards work with Suse 9.3? petermcp SUSE / openSUSE 3 08-05-2005 05:51 PM
What is a good wireless NIC card that will work with SuSE? abefroman SUSE / openSUSE 1 05-23-2005 12:28 AM
Unable to get Wireless Linksys WPC11 v4 to work with SuSE 9.1 trinityrock Linux - Wireless Networking 16 11-06-2004 02:14 PM
SUSE 9:Wireless network card doesn't work. sasquash Linux - Wireless Networking 9 12-22-2003 11:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 03:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration