LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   How do i set up WPA PSK with wpa supplicant and linuxant? (https://www.linuxquestions.org/questions/linux-wireless-networking-41/how-do-i-set-up-wpa-psk-with-wpa-supplicant-and-linuxant-230294/)

Eleavings 09-13-2004 09:48 PM

How do i set up WPA PSK with wpa supplicant and linuxant?
 
Hi,

I am using fedora core 2 2.6.8-1.521.stk16 with Linuxant DriverLoader driverloader-2.06_k2.6.8_1.521.stk16-1fdr.i686 and wpa_supplicant .0.2.4 with a PC Card DLink DWL-G650 with the win_xp drivers.

I need to set up the WPA PSK. When I set the SSID, channel and key in the Wireless Network config gui the result I get is system lock if I try to activate the card.

The card works fine btw under win_xp. Also, prior to trying to set the psk and using the 127.0.0.1:18020 web interface of Linuxant it all seems to work fine. Just locks up when I try to activate with the key.

What am I missing here? Is there a config file I should be adjusting?

Thanks

Eleavings

Fraudulent 10-03-2004 10:46 AM

Im having trouble too.
I don't get a lockup, but it never connects properly with my WAP.
I Use LinuxAnt with WPA supplicant.

crazibri 11-15-2004 12:39 PM

Hi guys, I'm using Linuxant w/ WPA supplicant on Suse 9.1. When I was configuring it, I set the ifcfg-wlan0 to have my network ID and mode is managed. Then I was able to make the wpa supplicant and then you just type ./wpa_passphrase networkID passphrase.
It will generate what you need to put in your own wpa_supplicant.conf file.
Then to run the actual WPA process, ./wpa_supplicant -Bw -i wlan0 -c <path of conf file>

This will run your wpa supplicant and you should be able to do ifconfig and view an IP address for your wireless card.

Does this help? Maybe you guys are having problems with the linuxant driver being installed?

Fraudulent 11-16-2004 07:56 AM

Thanks for your post!
The problems I have are basically the following (in I'm not sure if it is suse, linuxant or wpa supplicant related).

I have everything configured, and it works for a brief time if I have configured a static IP-address. After just a few minutes of inactivity I have lost the connection to my wap. I'm pretty sure that if my connection drops because of interference that it never reconnects to my wap.

If I have it configured for automatic IP (DHCP from my wap) it never gets an address.

I use netgear stuff, never tried anything else.

BarkingBonefish 12-27-2004 12:24 PM

Solution
 
I could not get network access after loading the supplicant, even though (in display mode, the handshake/key exchange worked fine). The problem is the card has already made contact with DHCP provider, so the WPA handshakes continue, but can not see outside the private network. DNS at play.

So I contacted tech support, and found out there are wpa_supplicant hooks in the dldr, so just need to make some minor changes to make the wpa_supplicant load automatically when Driverloader starts:

1) Move wpa_supplicant binary to /usr/sbin/ and rename to "dldr_wpa_supplicant"
2) Move wpa_supplicant.conf to /etc/driverloader/ and rename to dldr_wpa_supplicant.<interface>.conf, where interface is your interface name (mine was eth1)
3) Reboot

Worked fine, first shot, on FC3.

Cheers,

BB


All times are GMT -5. The time now is 10:53 PM.