LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-25-2006, 09:12 PM   #16
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15

No problem. In a month or so you'll be flying through the console and all the headaches will be a distant memory (I hope). One more thing that I want to mention. Do you have both a wireless (wlan) and an ethernet card installed on your computer? If you have both, you'll want to disable one of them and not have both interfaces up at the same time, otherwise you may have a problem getting on the internet. I don't know what the issue with this is just yet, but probably has to do with the order the interfaces are brought up. If you have an ethernet card on your computer also, you'll want to disable the interface by using:

ifdown eth0

That's if the interface for the ethernet card is eth0 (most likely). To see the interfaces that are setup run:

ifconfig

You'll also want to use YaST and set the ethernet card to be manually enabled if you use your wireless mostly (like I do). When you want to plug in to the router with a line, shutdown the wireless interface with:

ifdown wlan0

And bring up the ethernet with:

ifup eth0

Again this all depends on if you have an ethernet card also. Chances are you do. Just giving you a heads up. All the best....
 
Old 02-17-2006, 06:57 PM   #17
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
hey all, sorry i just left the things in between, i read all the support at that site and installed everything as it was mentioned there.....when i run "ifstatus wlan0" it gives me some nice output but i cant get connected to the internet, i think its problemm with DHCP ... if so then what should be done, here is the output for "ifstatus wlan0" :
Code:
hroot:~ # ifstatus wlan0
    wlan0     device: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    wlan0     dhcpcd is still waiting for data
wlan0 is up
4: wlan0: <BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:90:4b:54:ad:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::290:4bff:fe54:adcb/64 scope link
       valid_lft forever preferred_lft forever
wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"linux"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:00:00:00:00:00
          Bit Rate=54 Mb/s   Tx-Power:25 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:7EC5-6FD2-FEFC-C984-3AAF-3404-8C   Security mode:open
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:79100   Missed beacon:0

hroot:~ #
thx for ur help again
 
Old 02-18-2006, 08:12 AM   #18
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
You don't have an access point established. How do you have you're wireless router setup? Did you make sure it is operating in DHCP server mode? Also, do you have any MAC address filtering enabled on your router? Third, is it broadcasting your SSID? Did you ever have a wireless connection setup for your router, or is this the first time you're using it in this capacity? I'm not what you know about the wireless side of things, so I'm just throwing these things out. I notice also from the output that you have no SSID setup. You probably have something and don't know it. After you check these things and things still aren't right, then we'll take a look at some debugging features using the wireless tools package.
 
Old 02-18-2006, 01:43 PM   #19
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
Smile

ok this image is taken from windows as i can access my router settings from windows and not from linux ofcourse, i think this may help as it got all the info bout DHCP and my SSID and MAC adress and bunch of more things....

http://img464.imageshack.us/img464/8873/untitled9bj.jpg

thx for replyinggg...
 
Old 02-18-2006, 03:09 PM   #20
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
OK. Your router is set up as a DHCP server. Still don't know if you have MAC address filtering active, but let's assume you don't since generally the default is no. You are using WEP encryption. A few more questions 4 U:

1) Did you use YaST to setup your network card?
2) Please post your /etc/network/sysconfig/ifcfg-<interface> file. Open a konsole and type:

cd /etc/sysconfig/network
ls

You should see some files that begin with ifcfg-. Those are your network interface configuration files. Find the one that belongs to your wireless card. It will probably start with ifcfg-wlan-. Once you know the filename type:

cat <filename>

where <filename> is the name of the file. You'll have to be root to see this file. This will display the contents of the file. It would be nice to see some of your settings, but please do not post any encryption keys, i.e. generally any parameter that has a "KEY" or "PASSWORD" in its name or any parameter that has "WPA_PSK" in its name. Just blank those out before you post it. But don't blank out the "WIRELESS_KEY_LENGTH" parameter, that one is insignificant. It's just the number of bits for the encryption. In your case that should be 64 based on your router setup you posted. Let's take it from there....
 
Old 02-18-2006, 09:54 PM   #21
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
ok i got it, first of all MAC filter is off but IP filter is on.

1) yes i used Yast for network card setup.
2) here is the nice output :
Code:
hroot:/etc/sysconfig/network # ls
.       dhcp       ifcfg-eth-id-**:**:**:**:**:**  ifcfg.template  scripts
..      if-down.d  ifcfg-lo                        ifroute-lo      wireless
config  if-up.d    ifcfg-wlan0                     providers
hroot:/etc/sysconfig/network # cat ifcfg-wlan0
BOOTPROTO='dhcp'
BROADCAST=''
IPADDR=''
MTU=''
NAME='Ethernet Network Card'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='___AmAn___'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='h:**********'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK=''
_nm_name='wlan0'
hroot:/etc/sysconfig/network #
so what next, this thing is drivin' me crazy ughhhhhhhhhhhhhh..... loll but we'll get through it...............
 
Old 02-18-2006, 10:51 PM   #22
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
Thanks. Couple more things to check:

1) Do you have your ethernet interface running also? Type:

netstat -i

If you see both eth0 and wlan0, bring down eth0 with ifdown eth0. Also, bring down wlan0. Then bring wlan0 back up. If no dice, next step.

2) I noticed that your 'WIRELESS_KEY_LENGTH' is set to 128 in your ifcfg-wlan0 file. Edit that file and change it to 64. Then bring down wlan0 with 'ifdown wlan0'. Bring it back up with 'ifup wlan0'. If no dice, next step.

3) Go to /var/run directory:

cd /var/run

Post the 'wpa_supplicant-wlan0.conf' file here.

cat wpa_supplicant-wlan0.conf

Again, mask out any encryption key. Sorry this is taking so long, but I'm just trying to get an idea of your setup. I've sometimes spent 8 hours on a problem like this just to realize I forgot to set a flag on my router! Anyway, let me know.
 
Old 02-18-2006, 11:20 PM   #23
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
ok finally nothing works, and i got to last step, amazingly here are the results :

Code:
hroot:~ # cd /var/run
hroot:/var/run # ls
.               dbus       mdnsd.pid       resmgr.pid     sudo
..              hal        nscd            samba          sysconfig
.resmgr_socket  kdm.pid    ntp             sasl2          syslog-ng.pid
acpid.socket    keymap     openct          screens        uscreens
agentx          klogd.pid  powersaved.pid  smpppd         utmp
cron.pid        mdnsd      resmgr          sshd.init.pid  xdmctl
hroot:/var/run # cat wpa_supplicant-wlan0.conf
cat: wpa_supplicant-wlan0.conf: No such file or directory
hroot:/var/run #
there is no such file or directory, i mean howcome.. omggg................
 
Old 02-18-2006, 11:47 PM   #24
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
Check to see if you have the wpa_supplicant package installed. Type:

rpm -qa wpa_supplicant*

Anything?
 
Old 02-19-2006, 06:17 PM   #25
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
Code:
wpa_supplicant-0.4.4-2
just one line...
 
Old 02-19-2006, 07:02 PM   #26
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
You have it installed. This is getting stranger by the minute. What's reported when you bring the interface up with ifup, i.e "ifup wlan0". Does it say it's starting wpa_supplicant? Does it say its backgrounding? Also, after you try to bring up the interface type:

1) iwlist wlan0 key

What does it say? Also, did you try to use WPA PSK encryption instead of WEP? It's better anyway. Let me know...
 
Old 02-19-2006, 08:14 PM   #27
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
after i type "ifup wlan0" and hit the return key it says : starting DHCP deamon on wlan0..............no ip address yet, backgrounding.

and result of "iwlist wlan0 key" is here :
Code:
hroot:~ # iwlist wlan0 key
wlan0     2 key sizes : 40, 104bits
          4 keys available :
                [1]: ****-****-** (40 bits)
                [2]: off
                [3]: off
                [4]: off
          Current Transmit Key: [1]
          Security mode:open
          Authentication capabilities :
                WPA
                WPA2
                CIPHER TKIP
                CIPHER CCMP
          Current key_mgmt:0x0
          Current cipher_pairwise:0x0
          Current cipher_group:0x0


hroot:~ #
wut should be done next
 
Old 02-19-2006, 08:30 PM   #28
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
Let's backtrack. Did you remember to poke a hole in your firewall for DHCP client? Your ethernet card configuration should have taken care of this, but double check:

YaST -> Security and Users -> Allowed Services -> External Zone

Should have "DHCP client" in the list. Check also if you have a "/etc/wpa_supplicant-wlan0.conf" file when you try to bring up the interface. I'm curious.
 
Old 02-21-2006, 03:56 PM   #29
rgistered
Member
 
Registered: Jan 2006
Distribution: arch, CentOS
Posts: 83

Original Poster
Rep: Reputation: 17
YaST > Security and Users > Allowed Services > External Zone DHCP client was not added but i added it, restarted the pc, tried again but no luck, and /etc/wpa_supplicant-wlan0.conf <<<<< dosent exist... and when i do "ifup wlan0" it still says no ip address yet.......backgrounding. and again nothing... there must be something we are missing from somewhere
 
Old 02-21-2006, 06:10 PM   #30
card-suse
Member
 
Registered: Dec 2005
Location: Ohio, USA
Distribution: OpenSuSE 10.2
Posts: 74

Rep: Reputation: 15
OK. Let's try a different form of encryption for kicks. Does your router support WPA PSK, aka WPA (Personal)? If it does, change the encryption to that (probably under the wireless tab or pulldown seeing that on your image of your router setup screen from the previous posts). Then go to YaST and delete the interface for your wireless card and set it back up using WPA-PSK for your authentication mode along with "managed mode" and of course your key. I have the exact same card you do and of course using ndiswrapper and this is the setup I have. If this works, your in good shape. If not, then we need to make sure that your drivers are installed properly. After that, we search elsewhere.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A wireless cards that work with SuSE 9.2 RHLinuxGUY SUSE / openSUSE 3 10-07-2005 02:13 PM
Microsoft MN-720 wireless card to work on SUSE Linux 9.1 Professional maxtothemax1004 Linux - Wireless Networking 1 09-16-2005 12:08 PM
Which PCI wireless cards work with Suse 9.3? petermcp SUSE / openSUSE 3 08-05-2005 05:51 PM
How I got my wireless to work/SuSE 9.0 jxbrown Linux - Wireless Networking 1 12-26-2003 10:34 PM
SUSE 9:Wireless network card doesn't work. sasquash Linux - Wireless Networking 9 12-22-2003 11:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration