-   Linux - Wireless Networking (
-   -   Getting Broadcom 802.11g to work! (

Shioni 04-12-2006 06:48 AM

Getting Broadcom 802.11g to work!
I can't find modules for my Broadcom 802.11g wireless card. I have heard, that there are some application for wireless, that alows user to use windows drivers for wireless network adopters. Any suggestions? THank you!

Lenard 04-12-2006 09:19 AM

Visit the ndiswrapper site;

Shioni 04-16-2006 05:12 AM

Thanks! When I load the *.inf file in ndiswrapper and then load ndiswrapper module, I check the dmesg and get this:

ndiswrapper version 1.13 loaded (preempt=no,smp=no)
ndiswrapper (check_nt_hdr:155): Windows driver is not 32-bit; bad magic: 020B
ndiswrapper (load_sys_files:213): couldn't prepare driver 'bcmwl5'
ndiswrapper (load_wrap_driver:111): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'
I have a 64-bit CPU, but it's set to run in 32-bin mode! Any suggestions? Thank you!

Lenard 04-16-2006 08:44 AM

If the kernel (hint; see 'man uname') is 64-bit use the 64-bit Windows driver, if 32-bit use the 32-bit Windows driver. The Windows driver needs to be 32-bit as the messages informs you;

ndiswrapper (check_nt_hdr:155): Windows driver is not 32-bit; bad magic: 020B

Shioni 04-17-2006 04:55 AM

Thanks, got it working now!:)

ekko 04-23-2007 04:35 PM

Shioni, where did you finally find the 32-bit driver? I've got the same problem.


# uname -a
Linux localhost 2.6.17-5mdv #1 SMP Wed Sep 13 14:32:31 EDT 2006 i686 AMD Turion(tm) 64 Mobile Technology MK-36 GNU/Linux


pappy_mcfae 04-25-2007 04:34 AM

Same problem, different exposition.
I recently bought a new Compaq laptop. It has the broadcom bcm43xx wireless set up built in. I have the actual drivers from HP that came with the machine, and they work just ducky under XP. Not so good with ndiswrapper...:cry:

I have tried re-compiling the kernel to version (from 2.4.33), installing modules from other kernels, editing every rc. file that even hints and wireless operation, and using ndiswrapper to get things working. Simply put, nothing I have tried to this point has done diddly or squat in getting me up and running in a wireless fashion.

I ran demsg and got the following:


ndiswrapper version 1.42 loaded (smp=no)
ndiswrapper: driver bcmwl5 (Broadcom,10/12/2006, loaded
PCI: Device 06:00.0 not available because of resource collisions
ndiswrapper (start_pdo:49): couldn't enable PCI device: ffffffea
ndiswrapper (pnp_start_device:425): Windows driver couldn't initialize the device (C0000001)
unregister_netdevice: device eth%d/f6110800 never was registered
ndiswrapper (miniport_halt:332): device f6110960 is not initialized - not halting
ndiswrapper: device eth%d removed
Trying to free nonexistent resource <00000000-00003fff>
While it's fairly obvious that there's a conflict (which absolutely shouldn't happen with as many IRQ's as this machine supposedly has), I am at a loss to figure what to do next. I'm sure there are people who have gotten this same setup running properly. Is there anyone who has figured this one out?

FYI: the machine is
Compaq C504US
Celeron M @ 1.86 GHz
100 gig SATA hard drive
1 gig memory
DVD ROM / burner
Realtek 8139 NIC
Broadcom 1390 (bcm43xx) wireless lan
Conexant modem and sound card
Intel 945G video card
dual boot with Windows XP (downgraded from Vista (GAG!)) and Slackware 11. All the hardware (except the broadcom) works perfectly.

APM doesn't seem to want to work either, but that's not even a concern for me at this point. I want my wireless networking working! I suppose it's not of earth shattering importance, but considering what I paid for the machine, and the hell I went through to get XP working (and get rid of Vista (GAAAAGGG)), I'd like all the bells and whistles to work properly under both of my chosen operating systems.

Please help me out...the sleepless nights are getting a bit too intense.

Thanks in advance...

Blessed be!

Lenard 04-25-2007 06:20 AM

Some Broadcom devices work just fine with the bcm43xx kernel module, some do not. In these cases one has to blacklist the bcm43xx kernel module before ndiswrapper can work (your resource conflict maybe).

The Broadcom 1390 (bcm43xx) wireless device is reported to be a Broadcom 4311 chipset and should work without ndiswapper by following the suggestions here;

pappy_mcfae 04-28-2007 03:56 AM

ndiswrapper worked...sort of.
By that, I mean that the wireless adapter is now functioning in as far as the little blue LED that says the network adapter is functional comes on. That's miles ahead of where it was. I used ndiswrapper as the fwcutter solution was no solution at all. As a matter of fact, it caused my system to lock.

For those who are planning on using ndiswrapper, let me say right now you will need to run a 2.6.x kernel. Using the stock 2.4.33 kernel that was installed at initial installation bore no fruit at all. No matter what I did, ndiswrapper simply refused to work.

After I rebooted with the new 2.6.17 kernel, it was like magic. I returned from the bathroom to be greeted by the happy blue glow of the "I'm working now" LED.

Oh yeah, that reminds me. If you are going to compile a new kernel to work with ndiswrapper, make sure you include full support for the reiserfs into the kernel If your hard drive is formatted with reiserfs. Do not make reiserfs a module. Do not use initrd thinking that will get things humming. It will not! Only compiling full reiserfs support into the kernel will get the job done. Trust me, I compiled a 2.6.17 kernel for another machine that was formatted with reiserfs. Having the support for reiserfs as a module or an initrd setting resulted in kernel panic. Only when it was compiled into the kernel did it finish the boot process.

So there you have it! Ndiswrapper does, in fact, work. Now I am down to fixing the glitches in the rc.inet1.conf file to get the wireless network up and running as it should. I may back to ask more questions. Once I get things working properly, I'll come back to share exactly how I did it.

Blessed be!

All times are GMT -5. The time now is 04:35 PM.