LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-15-2005, 06:54 PM   #1
vladoportos
LQ Newbie
 
Registered: Dec 2004
Posts: 24

Rep: Reputation: 15
Failed to enable wpa in the driver


Hi i have strange problem with mi wifi card MIM2000 on my JoyBook 5000.
I use Mandrake 10.1 witha all updates, I also install ndiswrapper but that one witch was on cd as rpm.. It running ok with my card because i can scan for others SSID an if i run

-------------------------------
ndiswrapper -l
Instaled ndis drivers:
w70n51 hardware present
-------------------------------------------

I also installed latest wpa_supplicant and install run without problem.

BUT when i try

wpa_supplicant -Dndiswrapper -iwlan0 -c/home/vladoportos/wpa_supplicant.conf

it will give me this:

Failed to enable WPA in the driver
Failed to disable WPA in the driver



What can i do, what's wrong... i know that that driver support wpa because its work under xp...
 
Old 09-09-2006, 07:10 AM   #2
Melsync
Member
 
Registered: Sep 2005
Posts: 75

Rep: Reputation: 15
I did it this way

This a very old thread in pinguin terms, but since I struggled to solve the same problem, this might help others to try my solution.

This is a Fedora Core 4 with a ndiswrapper and wireless adapter working perfectly with wep. However wpa_supplicant gave this error: 'Driver does not support WPA'. I knew the driver did support WPA because it worked when my laptop was booted in Windoze.

1. keep /etc/wpa_supplicant/wpa_supplicant.conf to the bare minimum because the defaults are very generic for all situations

Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
        ssid="yournetwork"
        psk="yourpassword"
}
2. use the driver option 'wext' instead of 'ndiswrapper'
Quote:
sudo /usr/local/sbin/wpa_supplicant -ieth1 -c /etc/wpa_supplicant/wpa_supplicant.conf -Dwext -w
3. fire your network interface
Quote:
/sbin/ifup eth1
Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to enable DMA after upgrade to a DVD writer samael26 Debian 3 09-05-2005 01:31 PM
How can i enable WPA pre-shared key, wireless? spondootre Linux - Newbie 5 06-24-2005 02:12 PM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 12:24 PM
Proxim Skyline Driver & WPA support? RandallC Linux - Hardware 0 11-24-2004 12:39 PM
wpa enable access point on linux saajii Linux - Wireless Networking 0 05-19-2004 11:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration