-   Linux - Wireless Networking (
-   -   Ethernet/Wifi laptop connection problems (

killahwave 03-09-2004 08:29 AM

Ethernet/Wifi laptop connection problems
-Sony Vaio PCG-V505BL laptop with Fedora (kernel v2.422-1.2174)
-Orinoco Silver a/b card (madwifi driver)
-Earthlink DSL connection

Both ethernet and wifi devices work fine at home & school, but not at the location I am currently at. My wifi device constantly picks up/drops signals, and my ethernet device can't get past the D-Link router.

If I run iwlist ath0 scan, the ap is not detected.

ifconfig eth0
Link encap:Ethernet HWaddr: 08:00:46:AC:D3:6F
inet addr: Bcast: Mask:
RX packets:732 errors:401 dropped:0 overruns:0 frame:401
TX packets: 177 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes: 200688 (195.9 Kb) TX bytes:13735 (13.4 Kb)
Interrupt: 10 Base address:0x4000 Memory:e8202000-e8202038

ifconfig ath0
Link encap:Ethernet HWaddr: 00:20:A6:4B:D7:FE
inet addr: Bcast: Mask:
RX packets:20279 errors:655 dropped:0 overruns:0 frame:590
TX packets: 11624 errors:2 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes: 1326719 (1.2 Mb) TX bytes:445606 (435.1 Kb)
Interrupt: 3 Memory:e1d8f000-e1d9f000

BTW - I have an identical wifi router at my house, however use a cable modem for an internet connection.

Thanks in advance

andzerger 03-09-2004 09:26 AM

my theory is this:
your AP has an IP and your GW is set to something else, reset your AP at home, dig out the manual and find what its default IP is .. something like probably. Make sure your LT has a route to that IP (route add -net gw netmask then HTML to and play with the setup page until youve got it all figured out, it should work then
write some scripts to make it easier to juggle your various gateways

or i could be way off because you use DHCP at all three locations so my static based beta means nothing

id never seen iwlist before, so i could be way way way off. thanks for the new command.. apparantly my card 'doesnt support scanning' have any idea about what thats about?

killahwave 03-09-2004 10:09 AM

No clue - the madwifi drivers have limited functionality in terms of the linux wifi tools. That *happens* to work, where options/commands (iwspy) do not.

Is it possible that I need to be connecting w/ some sort of PPP client to the router, considering this connection is DSL? The original Windows XP installation (eth0) worked perfectly at this specific place. The computer I am currently typing @ (Windows 2000) has PPP dialer and LAN connection. The person administering the network has minimal networking knowledge (ie knows enough to setup/maintain), and my knowledge of DSL is minimal.

andzerger 03-09-2004 10:30 AM

re: dsl?
yeah i know nothing of DSL either and i dont plan on using it ever either .. i doubt thats what it would be though, since you use cat5 cable to connect to the DSL modem.. of course it doesnt hurt t try n linux is 4 learning if your not doing SETI or running a server, so i would say try it

i think the PPP vs. TCP/IP interface is all about the difference between phone lines and ethernet lines, in PPP, PPP pin1 meanssomething, pin2 meanssomething else, in TCPIP pin 1 means somethingelsestill and TCPIP pin2 means stillsomething else .. its all about electrified pin/wire combinations at a certain speed in a certain pattern .. so i dont think you need a PPP interface to talk through your ethernet cable..

are you getting your IP from DHCP?

killahwave 03-09-2004 11:25 AM

Ok -- I briefly searched, and found that the DNS needed to be changed to the local IP assigned to my machine. Eth0 works. Wifi does not :(

The essid of the network should be '817wifi' not linksys. The router may or may not be picking up the WEP key, as I don't use one at home and use vpn authentication at school.
Is it possible that I need to specify the WEP key in a place other than /etc/sysconfig/network-scripts/ifcfg-ath0?

]# iwconfig ath0
ath0 IEEE 802.11 ESSID:"linksys" Nickname:"mahalo"
Mode:Managed Frequency:5.8GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:6Mb/s Tx-Power:off Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:1979-ABCD Security mode:open
Power Management:off
Link Quality:0/94 Signal level:-95 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@mahalo killah]# ifup ath0
Cannot get driver information: Operation not supported

Determining IP information for ath0...PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.033/0.033/0.033/0.000 ms, pipe 2
RTNETLINK answers: No such process

root@mahalo killah]# ifconfig ath0
ath0 Link encap:Ethernet HWaddr 00:20:A6:4B:D7:FE
inet addr: Bcast: Mask:
RX packets:11328 errors:827 dropped:0 overruns:0 frame:400
TX packets:2890 errors:49 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:757804 (740.0 Kb) TX bytes:123321 (120.4 Kb)
Interrupt:3 Memory:e1d8f000-e1d9f000

killahwave 03-09-2004 11:28 AM

Here is /etc/sysconfig/network-scripts/ifcfg-ath0


andzerger 03-09-2004 09:35 PM

Mode:Managed Frequency:5.8GHz A.....

check to make sure your router at home isnt 2.4ghz, most mass marketed WLAN equipment is.
i tried to look up your orinoco card, but the page is down ATM for whatever reason

All times are GMT -5. The time now is 04:22 PM.