-   Linux - Wireless Networking (
-   -   Error, some other host already uses address (

nemobluesix 05-26-2008 01:25 PM

Error, some other host already uses address
This is starting to be an old problem for me, my wireless connection is not working since the kernel reduced the stack to 4kb (or something like that :) ).
Now I fresh installed fedora 9 (with new hopes) and when I ifup wlan0 it sais:

#ifup wlan0
Error, some other host already uses address

and I know there is no other.
I asumed that it might be already up and tried:

# iwlist wlan0 scanning
wlan0    Interface doesn't support scanning : Network is down

the output of iwconfig is:

# iwconfig wlan0
wlan0    IEEE 802.11  ESSID:"home_li"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7  RTS thr:off  Fragment thr=2352 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

my hardware is an acer aspire 5610z laptop with a Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

short history of the problem:
-back in the days of fedora 7 it worked
-after the kernel upgrade it stoped working giving an error message "set failed on device wlan0 ; Operation not supported"
-tried all kind of stuff to bring it up and finally there was no err, I could see the AP but had no ping
-current status is the one described above

any ideas guys?

Person_1873 05-26-2008 05:41 PM

have you considered setting it up with dhcp? or using a different ip address?

nemobluesix 05-27-2008 01:33 AM

Thanks for your reply, Person.
I tried a few other addresses but I've got the same message. I did not test it with dhcp but I will as soos as I get home (now I'm at work).

But couldn't it be that the interface starts to come up but somewhere along the way something goes wrong right after the ip gets registered?
How to test this?

[edit].... after a few hours, at home...
I tested with dhcp but nthing changed. the error is still there 07-04-2008 10:32 PM

hi nemobluesix,

I got same as this problem. Had you solved this? Please tell me how had you solved that? Please I am waiting.......................

nemobluesix 07-05-2008 06:55 AM

well, I followed the instructions from this link and everything was ok (I wasusing kernel After the next kernel update my system hung during boot. I don't know if it was because of the wifi or not but I continued to use my old kernel until now when everything runs smooth with

The link above is for my card, you may need to look for another page on that site, depending on your config.
I hope this helps, good luck! 07-09-2008 01:42 PM

Hi nemobluesix,

Thank you a lot of tons! Now I am getting enjoy with my

All times are GMT -5. The time now is 08:36 PM.