LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   error for wireless request "Set Mode (8B06) (https://www.linuxquestions.org/questions/linux-wireless-networking-41/error-for-wireless-request-set-mode-8b06-536808/)

Baracuda 03-12-2007 09:19 AM

error for wireless request "Set Mode (8B06)
 
The full error that I am getting is:

error for wireless request "Set Mode (8B06)
SET failed on device ath0; Invalid argument

The connection fails.

My OS is FC4 on a laptop, LC2210D. I have a Belkin Wireless G Router. The only change I made recently to the network configuration was to bind to my MAC address on the laptop and edit the allowed MAC addresses on the router. Even after the changes I was able to connect.

What is my next step to resolve this issue?
Thanks

MS3FGX 03-13-2007 02:10 AM

What mode are you trying to set?

There are only two reasons you will get that error. One is you are trying to set a mode the hardware doesn't support (like Monitor or Master) or two, you are trying to configure a device that doesn't have any wireless extensions (like an Ethernet card).

Baracuda 03-13-2007 07:42 PM

I am definitely attempting to use a wireless device unless when I set the MAC for the wireless I accidently set it for the ethernet device. How can I be certain what the MAC is for the wireless?

pioniere 03-20-2007 11:18 PM

I had the same issue in FC 5. I ran 'depmod' and it fixed it.

Baracuda 04-09-2007 04:10 PM

How do I use "depmod" to resolve my problem?

Baracuda 04-09-2007 04:15 PM

How do I use "depmod" to solve this problem?

I ran: depmod -e

I continue to get the same error.

short101 04-10-2007 03:36 AM

you still haven't said what you are trying to set. can we have the command and error as you see it?

reikred 12-21-2007 10:58 PM

It is very likely that the person asking does not or cannot know which exact command is causing the error message, because he is simply running
system-config-network and/or calling ifup wlan0 or something like that.

an one find out the exact offending command by tracing through ifup wlan0?

4ng3ls 11-27-2008 01:32 PM

hey there
 
i have exact the same trouble, let me explain myself.

i have an acer aspire 4320 with a wireless card atheros ar5007eg, i have two partitions on my laptop one for xp and the other one for the fedora 9 (i have to tell i kind of ... nahh i actually a newbie on linux) i install fedora 9 and then i couldnt find my wireless card, so reading i see that madwifi exist and i download and install the madwifi drivers, it looks working i found wlan0 and everything looks pretty normal, but .... i can not connect to my wireless lan.

So i go back on my steps and checking this new whole and unknowing world and i found network giving me this message, i couldnt activate the device because 8b06, so i can not connect on any wireless lan.

So i hope that you can help me,

greetings

4ng3ls 11-27-2008 02:30 PM

finally did it
 
Im going to write at least my solution here, i feel pretty stupid after figure out what was the problem or what was going on on my last post.

I can see that the problem it wasnt on my card or the madwifi drivers, or something else, the problem it was at the configuration of the wireless.

Please i recomend that double check the configuration of your wireless, my problem was security mode "open" or "shared".

and it get done.


All times are GMT -5. The time now is 02:36 PM.