-   Linux - Wireless Networking (
-   -   Error for wireless request "Set Encode" (8B2A), help me (

jiasen_ma 05-17-2006 10:27 AM

Error for wireless request "Set Encode" (8B2A), help me
Hello, there,

I have a laptop running Fedora 4(i386). It worked well with two institution wireless network(access points in my school).
They are both MAC listed and one is also encryption enabled.
Recently I installed DSL and wireless router in my apartment. This worked fine with two windows machines. It also worked fine with my linux laptop if I use ethernet cable.

I set WEP key in /etc/sysconfig/network-scripts/ifcfg-ath0 as KEY=abcd123456789.
This is the same syntax I used for the network at school.
Then when bring the network up by /etc/init.d/network start as root, I get error messages:

Error for wireless request "Set Encode" (8B2A) :
SET failed on device ath0 ; Invalid argument.

I googled quite a while, but no solution yet.

One thing is if I do: KEY="s:abcd123456789" in ifcfg-ath0. The error message is gone.
But it will hang at the step of determining IP address.

Can anyone help me? By the way, what does "s:XXXXXXX" mean?

jiasen_ma 05-18-2006 10:17 AM

My wireless card is AT&T plug&share Model 6700G
My router is ZyXEL / HomeSafe HS-100W / 54Mbps / 802.11g / 4-Port / Wireless Router

fenwick1 05-23-2006 02:19 PM

Not sure what the s: is but I need to use also.

Just from trouble shooting perspective you may what to try and remove all enc and network restart see if will get an IP from AP. If it does then all your other setting are ok and your enc key is off.

jiasen_ma 05-25-2006 12:31 AM

Thank you very much. I disabled the encyption key of my router, then it works!
But I don't understand why my Fedora don't like the WEP encryption.
I have it set as: static WEP, 128bit, auto, 13 chars.
What do you mean by "enc key is off"? The other machine works fine with the router setting.

fenwick1 05-25-2006 03:33 PM

Since the system works when the encyption is off this means all your other settings are right. You should be able to set the encyption key using iwconfig (interface) enc s:(13 digit code)

and btw s: is to use an ascii string the default is hex.

This is where the problem most likely lies.

All times are GMT -5. The time now is 10:41 AM.