LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   DWL-122 USB and SuSE 9.1 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/dwl-122-usb-and-suse-9-1-a-212344/)

StormShadow 08-01-2004 11:43 PM

DWL-122 USB and SuSE 9.1
 
OK, I have read numerous tutorials on configuring Linux to run a wireless network, and I cannot find something to address the DWL-122 and SuSE. I have tried using YaST, and I configured the card, but Linux won't interface with the card. I checked on my Windows router connected computer and it pics up the DWL's MAC...but Linux does not recognize the USB as the source for the internet. What do I need to modify, is their an easy fix or am I going through NDISWrapper and recompiling of the kernel to make everything jive? Can anyone save me so I can get away from Windows....

StormShadow 08-02-2004 01:29 AM

OK update, I tried the Julian Coccia FAQ on the DWL-122, and I tried the Guide that was posted up here, and neither have worked. For the guide here, the part where you execute
iwconfig wlan0 essid [SSID]
Linux spit back:
Error for wireless request "Set ESSID" (8B1A):
SET failed on device wlan0; Operation not supported.

As for the Julian Coccia FAQ, everything went fine until I got to the ifconfig command, and when I tried to execute the command:
ifconfig wlan0 [IP] netmask 255.255.255.0
It said that command wasnt supported, but when I queried wlan0, it showed the IP and netmask I just entered. Then when I go to execute
route add -net default gw [router IP]
It doesn't support this command either. I can get the errors returned from these commands if it helps. PLEASE can anyone help me on this? Thanks all.

juliancoccia 08-02-2004 05:02 PM

First of all, with the DWL-122 plugged in, make sure that lsmod shows these two:

prism2_usb
p80211

Otherwise, make sure the modules are correctly loaded. I have just added a note for 2.6 kernel users on my article:
http://julian.coccia.com/article-53.html

What does iwconfig wlan0 say ?

StormShadow 08-02-2004 08:26 PM

ok, lsmod yields:
prism2_usb 70148 0
p80211 30608 1 prism2_usb

iwconfig wlan0 yields:
wlan0 no wireless extensions

Does this help point to my problem at all? I will go back through your help guide, which I really appreciate, and see if I can make some headway. I skipped past the kernel compilation and the latest linux-wlan-ng drivers were already installed (as far as I could tell). My tail message when I plug in and unplug the DWL did not look like yours, if you need that readout I can get it to you as well. Thanks for all your help and information, its greatly appreciated.

david_ross 08-03-2004 02:36 PM

Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.

StormShadow 08-03-2004 08:03 PM

thanks, appreciate the move, guess I didn't look closely enough at where I was posting.

StormShadow 08-08-2004 06:59 PM

Anyone have any ideas? Bueller?

okinawaman 10-10-2004 02:20 AM

Anyone have any new info to add, I am having a heck of a time trying to get this installed.

When I run tail /var/log/messages -f I get

Oct 10 01:48:28 linux kernel: usb 1-1: new full speed USB device using address 3
Oct 10 01:48:28 linux kernel: usb 1-1: SerialNumber: 000000000000
Oct 10 01:48:28 linux /etc/hotplug/usb.agent[5973]: need a device for this command
Oct 10 01:48:28 linux /etc/hotplug/net.agent[5974]: SIOCSIFFLAGS: No such device
Oct 10 01:48:33 linux ifup: No configuration found for wlan0

Can anyone help with that?

Thanks
Eric


All times are GMT -5. The time now is 09:38 PM.