-   Linux - Wireless Networking (
-   -   DSL connection slow on Linux wired connection but fast on Windows wireless (

Pandarsson 12-16-2007 10:55 PM

DSL connection slow on Linux wired connection but fast on Windows wireless
Hi. I'm finally writing after a year of noticing this problem.

I have a Windows laptop and a Linux desktop. I run openSuSE 10.2 on my desktop. I get DSL from AT&T (the fastest they offer) and use a 2wire HomePortal 1000HG as my modem/router. The 2wire has a port for one wired connection and you can connect a certain number (that I don't recall) via a wireless network card. I have my Windows laptop connected wirelessly and my Linux desktop connected with a fairly long network cable that goes from one room, though a hallway and into another room (I mention this in case the length of the cable affects speed for some unfathomable reason).

So why does my laptop's downloads run so snappy and on my desktop, it's sluggish to the point that I might as well be using dialup - in a way. I say "in a way" because once a download starts, it's obviously DSL speed, but the time required for it to start is ridiculous. I'll type a URL into Konqueror or Firefox and a minute later it starts loading the page (or there about) and it takes forever to load the page as different elements of it (images and whatnot) don't start. For the most part, everything eventually loads. I wondered about something being wrong with resolving the names to ips, but I tried loading a web page from an ip address and got the same thing.

My desktop has always been this way ever since I got DSL.

I should also mention that the few times I've booted to my Windows 98 partition that I keep forgetting to remove from my desktop machine, it's gone at a decent speed.

Anyone have any idea?

violettheconqueror 12-17-2007 01:32 AM

Did this start only after you got DSL? The length should not affect it unless the cable is shady, I've had cables with bad connectors mess with my internet speeds since it keeps needing to resend data.

Some things you could try to narrow the problem are:
Use something like Damn Small Linux or some other bootable distro (it seems they all are now) and see if you still have that problem. If not then the problem is with your install of SUSE. Maybe it doesnt like your lan card or something, you could reinstall and see if that fixes it, or look into what kind of driver you are using. It looks like there is a new version of SUSE out anyway. (I really don't know much about SUSE, it always seemed too sluggish for me)

Try bringing your linux box to a freinds house and see if the problem happens there. If it doesnt then it must be the modem being unfreindly to linux.

Last thing you could do is try and find a PCI lan card that someone might have floating around. Me and my freinds seem to be leaking old hardware from our pores so chances are someone has one they don't need, at least for testing purposes. This could bring up other problems by having two lan adapters on one computer, like I said, I dont know SUSE very well, it could have a great network manager.

Hopefully one of these things turns up a result for your problem.

archtoad6 01-13-2008 09:52 AM

Off Topic
PEBKAC is the more accepted acronym :)

Pandarsson 01-13-2008 12:03 PM


Originally Posted by archtoad6 (Post 3021011)
Off Topic
PEBKAC is the more accepted acronym :)

archtoad6: To imply that somehow I've done something to cause this problem is a bit of a stretch.

violettheconqueror: Thank you for the suggestions. I got a newer, more expensive cable (the previous one I bought from a bin, so suspected that it might be flaky), however that didn't improve things. Haven't tried anything else thus far because a) I either haven't had time or have been lazy (it's a fine line) and b) I haven't used my desktop much except for doing actual work not requiring the internet. However, when I do get around to it, I'll post my results here.

archtoad6 01-13-2008 01:17 PM

I was commenting on violettheconqueror's sig., not on you or your post. My apologies for the confusion & the unintended insult.

BTW, where in Houston? -- Have we seen you at any HLUG meetings?

Now let's back to an interesting topic. . . .
How much does "DSL from AT&T (the fastest they offer)" cost & what is the name of the plan?

You could bring both computers to the HLUG Wed. Linux Workshop held at HAL-PC. You can compare their performance on the club's high speed 'Net connection. We also (especially w/ advance notice) could probably find an alternate NIC for you to try. Finally, we tend to have a small selection of live CD's handy.

Pandarsson 02-23-2008 03:57 AM

Sorry it took so long to reply to this. I've become a recent convert to Kubuntu and plan to switch my desktop machine to this (once I get more information about switching from an rpm-based system to a dpkg-based one) and see if it changes anything - if not, I'll start looking at hardware. I have to say that on my laptop, Kubuntu's pretty snappy with my wireless card. In fact, I've been spending all my time on the laptop since I've installed Linux on it and so have neglected my desktop - hence my lack of action in trying to figure anything out about it. In any case, when I figure it out, I'll post back for anyone else with similar problems.

Archtoad - sorry about the confusion. If the offer's still open to check out HLUG, I'd like more information. Feel free to email me. As far as AT&T's plan, according to my router (they call it a "gateway" for some odd reason - it's a mostly wireless router with a built-in modem), my connection speed is 6016 kbps incoming and 768 kbps outgoing. It's 35 bucks a month and I forget the name of the plan.

dryicerx 12-22-2008 10:59 AM

I had the exact same problem, I came to visit St. Louis and the access point where I was staying was a AT&T 2WIRE??? DSL. Everyone's Windows machines seemed blazing fast, but my Linux (Fedora 9) seemed to to slow as balls.

I realized it was a DNS issue since the lag was when trying to resolve domain names. I used NetworkManager to connect to the wireless, but when it connects sets the Router as the DNS server.


Go to the router and find the DNS servers it uses (for me it was, if you are in the St. Louis area). For NetworkManager, go to edit settings and set the DNS server for the access point as these two. Problem solved.

archtoad6 12-23-2008 07:50 AM

"With 7 regular meetings per month, 4 social meetings, & 2 related Samba meetings, HLUG is the most active LUG in the world."

The weekly (except holidays) Wednesday Workshop meets from 6-9 pm at HAL-PC in the Galleria area. Afterward, we adjourn to Byzantio on West Gray (virtually at Taft) Coffee Groundz, for food, drink, talk, & free WiFi. You don't have to come to the "regular" meeting to come to the "after party". We have at least one regular who usually works 'til 9, so that is when we see him.

Pandarsson 12-17-2010 03:11 PM

Update, Three Years Later
I'd forgotten about this thread until now. Thanks to Google Alerts for letting me wrap this up.

A while after this thread, I found out that the problem was IPv6. I turned it off in the config and everything was fine. I found out that later versions of openSUSE had it off, so after doing a more recent update, I had no more problems.

I'm not sure if it's still kept off or if the problem has been fixed, but I haven't run across it since.

archtoad6 12-17-2010 05:55 PM

Thanks for posting the solution. That's the LQ spirit. +5

Still haven't detected you at an HLUG meeting. :(

All times are GMT -5. The time now is 04:56 PM.