LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 04-15-2008, 11:11 AM   #1
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
DLink DWA 552(Atheros AR5008) on 64bit Linux


Setup: I am on Sabayon 3.5Loop 2 which means the 2.6.24.2 Kernel with extended wireless support and the DLink DWA 552 wireless N desktop card which uses the Atheros AR5008 chipset.

The lspci shows this:
Quote:
Network Controller: Atheros Communications, Inc. AR5416 89211abgn Wireless PCI Adapter (rev 01)
net-setup, ifconfig and iwconfig show nothing, as if the card doesn't exist.

Thus far I have tried the latest madwifi.org drivers (.94) but they apparently have no support for the AR5008.

So, I moved on to the ndiswrapper idea. I have tried 4 versions of the drivers... the Vista 64 drivers don't work, and as the ndiswrapper wiki states I received about a hundred symbol errors. So I backed that out and tried the latest 32bit Windows XP drivers which give this error:
Quote:
[ 1555.147688] ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
[ 1555.156262] ndiswrapper (check_nt_hdr:150): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
[ 1555.156272] ndiswrapper (load_sys_files:210): couldn't prepare driver 'net5416'
[ 1555.157231] ndiswrapper (load_wrap_driver:112): couldn't load driver net5416; check system log for messages from 'loadndisdriver'
I searched around some more and found this version from Atheros which claims to be for Windows XP 32bit and 64bit which came with two different inf drivers. So I tried both. One loaded with similar errors to the above, the other did this:
Quote:
[ 3621.304188] ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
[ 3621.316983] ndiswrapper (link_pe_images:576): fixing KI_USER_SHARED_DATA address in the driver
[ 3621.321065] ndiswrapper: driver netathwx (,01/17/2008,7.4.2.75) loaded
[ 3621.321566] ACPI: PCI Interrupt Link [APC4] enabled at IRQ 19
[ 3621.321577] ACPI: PCI Interrupt 0000:01:07.0[A] -> Link [APC4] -> GSI 19 (level, low) -> IRQ 19
[ 3621.746415] ndiswrapper (__chkstk:2476): not fully implemented (yet)
[ 3621.746434] Unable to handle kernel paging request at 0000000100000000 RIP:
[ 3621.746437] [<ffffc2001176a146>]
[ 3621.746441] PGD 43c3d067 PUD 0
[ 3621.746444] Oops: 0000 [1] SMP
[ 3621.746447] CPU 0
[ 3621.746449] Modules linked in: ndiswrapper(F) snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device ipv6 nvidia(PF) forcedeth snd_intel8x0 pcspkr i2c_nforce2 k8temp snd_ac97_codec ohci_hcd i2c_core ac97_bus ssb pcmcia tg3 e1000 scsi_wait_scan sl811_hcd uhci_hcd ehci_hcd
[ 3621.746544] Pid: 14433, comm: modprobe Tainted: PF M 2.6.24-sabayon #1
[ 3621.746547] RIP: 0010:[<ffffc2001176a146>] [<ffffc2001176a146>]
[ 3621.746550] RSP: 0018:ffff8100500fb79d EFLAGS: 00010297
[ 3621.746553] RAX: 0000000000000000 RBX: ffffc20011660000 RCX: 0000000000000001
[ 3621.746555] RDX: 0000000100000000 RSI: ffff810043020000 RDI: 0000000000000000
[ 3621.746558] RBP: 0000000000000001 R08: ffffc20011694000 R09: ffff810001012f60
[ 3621.746561] R10: 0000000000000000 R11: ffffffff802212ff R12: ffff810047d20000
[ 3621.746564] R13: 0000000000002400 R14: ffff8100500f0014 R15: ffff810001012f60
[ 3621.746567] FS: 00002b666274fb00(0000) GS:ffffffff80b48000(0000) knlGS:00000000f74a26d0
[ 3621.746570] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 3621.746573] CR2: 0000000100000000 CR3: 00000000465af000 CR4: 00000000000006e0
[ 3621.746576] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 3621.746579] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 3621.746582] Process modprobe (pid: 14433, threadinfo ffff8100500fa000, task ffff8100728c6810)
[ 3621.746585] Stack: 0000000010ffffc2 001176c3ff000000 00500fbb68ffffc2 0000000000ffff81
[ 3621.746589] 0047d23800000000 ff889b4a98ffff81 0000000348ffffff 004302f000000000
[ 3621.746593] 001176a09affff81 00117149b3ffffc2 0011662000ffffc2 004302f2b8ffffc2
[ 3621.746596] Call Trace:
[ 3621.746642]
[ 3621.746643]
[ 3621.746644] Code: 0f b6 14 10 8d 42 d4 83 f8 4c 0f 87 10 03 00 00 48 98 41 0f
[ 3621.746651] RIP [<ffffc2001176a146>]
[ 3621.746653] RSP <ffff8100500fb79d>
[ 3621.746655] CR2: 0000000100000000
[ 3621.746665] ---[ end trace a2c920796b793957 ]---
I am pretty much grasping at straws now, so before I attempt the new Ath5k module support that madwifi says is in the latest mm series of the 2.6.25 git kernels, does anybody have any other ideas?
 
Old 04-15-2008, 07:08 PM   #2
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
If you want to use 64 bit you will probably have to use madwifi. Vista drivers will not work with ndiswrapper and that 64bit XP driver looks dubious. In any case the kernel doesn't seem to like it. Oops's are a very bad sign and something you generally want to avoid.

As you have noted however there does not exist an official release of madwifi release compatible with the 5008 chipset (draft n) series. It is however supported in the pre-release which can be downloaded via subversion. The the post below for a link on how to do that.
 
Old 04-15-2008, 07:10 PM   #3
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
Wikipedia article on kernel oops with a cursory explanation of why they are bad: http://en.wikipedia.org/wiki/Linux_kernel_oops.

How to pull the lastest madwifi development snapshot:
http://www.thinkwiki.org/wiki/How_to...ver_for_ar5008

Last edited by kevmitch; 04-15-2008 at 07:18 PM.
 
Old 04-15-2008, 07:17 PM   #4
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
It might be worth telling the ndiswrapper people about that oops in a bug report.
http://ndiswrapper.sourceforge.net/j...id,33/id,bugs/

Or you could report it through your distribution if they package the ndiswrapper you have installed and have some sort of bug report system.
 
Old 04-15-2008, 10:16 PM   #5
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
Muah ha ha. Thank you kevmitch, I was unaware there was support in the madwifi development snapshot. That puppy works. Just gotta get my WPA up, and I am running. Thank you.
 
Old 04-16-2008, 12:54 AM   #6
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
According to articles online, I merely needed to emerge wpa_supplicant and go through the knetworkmanager. So I emerged both latest versions successfully.

In the knetwork manager I can see my network listed properly, but when I try to connect, it gets to 28% "Activation stage: Configuring device." and then fails. I know I have the correct settings and correct device; I check use encryption and change the Encryption to WPA Personal. I put in my passphrase (even show credintials verifies I am typing it correctly) and change the WPA Version to WPA2 (which is set on my router) and the WPA protocol to AES, again as recommended by my router. I have tried every variation of this with both WPA1 and WPA2 an all 3 protocol settings all yield the same result.

On my Windows laptop I had to go through a "Add wireless device" phase for my router to recognize the card as accepted. It seems that is what wpa_cli is for, however I cannot run that, as I receive this error:
Quote:
Failed to connect to wpa_supplicant - wpa_ctrl_open: Connection refused
I have played around quite a bit, and my current wpa_supplicant.conf looks like this:
Quote:
network={
pairwise=TKIP
group=TKIP
ssid="Starfury"
proto=WPA
key_mgmt=WPA-PSK
#psk="REMOVED"
psk=LONGSTRINGOFSTUFF
}
I know I am probably missing something obvious, but for the life of me, I can't seem to find out what throughout like 70 pages from googling.
 
Old 04-16-2008, 02:15 AM   #7
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
In regards to wpa_cli:
A regular user doesn't have permission to access the socket of a running wpasupplicant. One solution is to run wpa_cli as root. A better solution is to add yourself to a group with permissions to access the socket. This is probably specified at the top of you wpa_supplicant.conf as something like

ctrl_interface_group=netdev

this means that you should be able to

adduser <you> netdev

log out and log back in and then run wpa_cli to your hearts content. For day to day use, you might also want to check out wpa_gui which does basically the same stuff in a more user friendly way.

If this doesn't work, is wpasupplicant already running when you run wpa_cli? wpa_cli needs to connect to a running wpa_supplicant in order to do anything.

My advice would be to try disabling all encryption/authentication on your router at first and try and get a connection that way. Once you've established that this is possible, start adding the security features in.

Unfortunately, I'm not familiar with your distro. In particular, I don't know the correct way to set up a roaming network interface. Perhaps someone with more knowledge in this area can pipe in.
 
Old 04-16-2008, 10:06 AM   #8
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
I should have mentioned, but when configuring wpa_supplicant.conf and basically all the supplicant settings, I had to run as root anyway. So I was running everything you see above as root in a terminal, including wpa_cli as root when I received that message.

I have never used WPA before, but I had WEP working on my old G equiptment. Until WPA however, you cannot run at N speeds. I will try removing all authentication temporarily when I get home.

I have never used WPA before, thus I have never used wpa_supplicant before. Apparently my thought of how it worked is wrong. There isn't a run command so I guess I assumed all I was doing was setting configuration which would be used later by other programs like knetworkmanager. As far as wpa_supplicant being "running"... I am embarrassed to admit, but I am not sure how I would tell that. I didn't know it was a running process. Would it show up as a module in lsmod or would I have to view all running processes?
 
Old 04-16-2008, 03:12 PM   #9
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
I forgot to mention that I strongly doubt that you'll get n-speeds. Though do tell if you do! I have an AR5418 and a router with the 5008 chipset family as well. No dice. The madwifi support appears to only be for abg. The kernel message when you probe ath_pci mentions nothing about n rate capabilities. You can check this for yourself by running "dmesg" immediately after probing the module. I do get n in windows, but strangely enough even using the 32 bit windows driver in ndiswrapper with a 32 bit kernel doesn't get me n speeds, so you're probably better off sticking with madwifi.

As for running wpa_supplicant, don't be too embarrassed. I have it running perfectly, and still don't really understand the rationale behind it all. There should be a running process called wpa_supplicant. You can run it quick and dirty on the command line just to see if it works with something like

wpa_supplicant -Dmadwifi -iath0 -c/etc/network/wpa_supplicant.conf

There should be some way to have something like this run automatically, but this is distribution-specific. As for knetwork manager, I'm not exactly sure how it fits in the picture (though I'm not saying it doesn't). I usually just use wpa_gui to select my network, tough if you can get it set up in roaming mode (again the exact procedure will depend on how your distro does networking), it should connect automatically to the network in wpa_supplicant.conf with the strongest signal with no user intervention at all.

Last edited by kevmitch; 04-16-2008 at 03:16 PM.
 
Old 04-16-2008, 03:51 PM   #10
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by kevmitch View Post
There should be some way to have something like this run automatically, but this is distribution-specific. As for knetwork manager, I'm not exactly sure how it fits in the picture (though I'm not saying it doesn't). I usually just use wpa_gui to select my network, tough if you can get it set up in roaming mode (again the exact procedure will depend on how your distro does networking), it should connect automatically to the network in wpa_supplicant.conf with the strongest signal with no user intervention at all.
Well, the speeds are listed as supporting N for me, I am guessing due to my placement and distance it says it would get 62 through knetworkmanager, but until I connect for sure I won't know. My windows laptop gets 120Mb at that same distance, but the card isn't hidden behind the nest of wires behind my tower against the wall either.

This is part of my problem here is... I cannot run the wpa_gui. You can see the exact error in my previous post, but essentially it says it can't connect to the supplicant. I am now beginning to guess this means my supplicant isn't running given that it is a process... so maybe that is the point I need to focus on, but I thought the gui was for configuring it, not for doing something afterwards. I thought it would help me get that damn wpa_supplicant.conf configured correctly, which I believe to be most of my problem. I hate editing text and configuration files manually. If this is not the case, what is the wpa_gui for?
 
Old 04-16-2008, 07:09 PM   #11
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
wpa_supplicant.conf configures wpa_supplicant's behaviour once it's been started. It doesn't contain any information about HOW to start wpa_supplicant. That's up to your distros networking scripts. To check if wpa_supplicant is running.

ps -A | grep wpa

Now that I start fiddling with things however, it looks like there are a few global settings in my wpa_supplicant.conf file that you might be missing. Try adding the following lines to the beginning of the file and restarting any running wpa_supplicant:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=netdev
update_config=1

The first line is the location of the socket to which wpa_cli and wpa_gui will connect. It appears that I get the error you describe without this line. Presumably because no socket gets created. The second line is the name of the group to which non-root users must belong in order to connect to the socket using wpa_cli and wpa_gui. The final line says that wpa_supplicant is allowed to edit the file on behalf of said clients.

Where does it say that n speeds are supported? All I get from dmesg is
Quote:
loading ath_pci
[18023.074407] ath_hal: 0.9.30.13 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133)
[18023.081880] wlan: svn r3545
[18023.090473] ath_pci: svn r3545
[18023.090567] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
[18023.090586] PCI: Setting latency timer of device 0000:03:00.0 to 64
[18023.223390] MadWifi: ath_attach: HAL managed transmit power control (TPC) disabled.
[18023.223437] MadWifi: ath_attach: Interference mitigation is supported. Currently disabled.
[18023.225218] MadWifi: ath_attach: Switching rfkill capability off.
[18023.231135] ath_rate_sample: 1.2 (svn r3545)
[18023.232898] wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[18023.233119] wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
[18023.233249] wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[18023.233442] wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[18023.233603] wifi0: turboG rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[18023.233782] wifi0: H/W encryption support: WEP AES AES_CCM TKIP
[18023.233918] wifi0: ath_announce: Use hw queue 1 for WME_AC_BE traffic
[18023.234015] wifi0: ath_announce: Use hw queue 0 for WME_AC_BK traffic
[18023.234109] wifi0: ath_announce: Use hw queue 2 for WME_AC_VI traffic
[18023.234203] wifi0: ath_announce: Use hw queue 3 for WME_AC_VO traffic
[18023.234295] wifi0: ath_announce: Use hw queue 8 for CAB traffic
[18023.234388] wifi0: ath_announce: Use hw queue 9 for beacons
[18023.242276] ath_pci: wifi0: Atheros 5418: mem=0xedf00000, irq=17
[18023.245402] net wlan0: device_rename: sysfs_create_symlink failed (-17)
[18023.245681] udev: renamed network interface ath0 to wlan0
Maybe they have n support for the 5416 chips but not 5418, or better yet, maybe I'm missing something and that might allow me to enjoy n speeds.
 
Old 04-20-2008, 12:23 PM   #12
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 04-21-2008, 11:56 AM   #13
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
Okay, well here is a little update since I messed with it this weekend. I tried everything I could, and in Linux, I could not force a connection from my tower to the Router. I disabled the connection security, and turned off WPA, and couldn't even connect totally unsecured. I am still not sure why, but perhaps it is because it is an unsupported development build. Maybe I should try the ath5k built into the kernel, but I will wait for that kernel to go mainstream, I don't really want to use a git. If anyone does find a totally legit way for this to work, please let me know, in the meantime, I will probably just use wire strung a hundred feet across the floor when in Linux.

That said, I partitioned out some space, and reinstalled Windows XP 64 on that tower. I installed the card via drivers from Windows Update and it runs at 130MB having absolutely no problem connecting whatsoever. This is with both WPA and connection security on.
 
Old 04-21-2008, 01:26 PM   #14
kevmitch
LQ Newbie
 
Registered: Apr 2008
Posts: 11

Rep: Reputation: 0
Unfortunately, ath5k doesn't have support for the 5008 chipsets, so that's not likely to be the solution for the time being. The good news on that front though is that Atheros has decided to stop being part of the problem and has actually hired an ath5k developer with the intent of seeing all their hardware supported in Linux http://lwn.net/Articles/278132/. This means that supporting the 5008 chipsets no longer has to be a herculean feat of reverse engineering.

As far as ath_hal is concerned, there are indeed problems associated with the preliminary nature of the driver, but as far as I know, no connection at all isn't usually one of them. Am I to assume that you got wpa_cli and wpa_gui working? What kind of router do you have?

One thing you could do to try and figure out what's going on is to start wpa_supplicant in debugging mode by adding -dd to the command I cited earlier:
Quote:
wpa_supplicant -dd -Dmadwifi -iath0 -c/etc/network/wpa_supplicant.conf
Another debugging trick for the kernel module itself is to run
Quote:
echo 0xc80000 > /proc/sys/net/ath0/debug
dmesg
 
Old 04-21-2008, 03:52 PM   #15
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Original Poster
Rep: Reputation: 45
It could also be the nature of my current unstable build after having screwed up so many settings in the attempt. It's tough to roll them all back out and start over.

When there is a new more stable, and more current release of Sabayon, hopefully the 3.5 full, I will give this another go, in the mean time, it just isn't worth the time, or effort for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Dlink DWA-542 on Suse 10.1 meping Linux - Wireless Networking 0 04-07-2008 11:38 PM
DLink DWA-642 PCMCIA on Slackware 10.2 xorphil Linux - Wireless Networking 1 12-14-2007 03:44 AM
Atheros AR5008, OpenSuse 10.3 (X86-64), ASUS C90S, AR5416.sys Karl65 Linux - Wireless Networking 2 10-29-2007 06:03 AM
don't know how to config for a Atheros Dlink wireless crd edkwok Linux - Wireless Networking 2 06-16-2007 09:51 PM
Atheros dlink pcmcia card, kismet does not detect any networks. jimdaworm Linux - Hardware 2 03-28-2006 12:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration