-   Linux - Wireless Networking (
-   -   DHCPDISCOVER appears to listen on wrong adapter (

Gardoglee 09-28-2008 12:01 PM

DHCPDISCOVER appears to listen on wrong adapter
I am having a problem with DHCPDISCOVER on my wife’s Asus Eee 2G running Xandros and using an Atheros internal WiFi adapter. The problem, which seems very similar to what many others have described in posts on various sites including this one, seems to be related to dhclient and the exchange of DHCPDISCOVER requests and responses between the adapter and the access point.

The odd circumstances are that when we are on the road with the Eee and it is configured to use DHCP for IP addressing it works flawlessly. The problem we have only occurs when we are at home. We have a DSL line with an Actiontec DSL modem which also supplies a WiFi access point. As such this single unit is supplying the DHCP server function for both wired and wireless connections, which seems like may be part of the problem we are experiencing.

When we are at home I can get the Eee to connect through WiFi by setting the config to have a static IP address. However, if I set it to DHCP the dhclient does not get a DHCP response. This seemed odd because I can use other machines running Windows or Solaris against the same access point and not have problems. I also have tried replacing the access point, with the same results.

I am running WPA with a pre-shared key. I have messed with the key, tried dropping back to WEP, have tried turning on and off SSID broadcast from the AP, and various other tricks. I have also tried various configuration file changes suggested by the various postings in various sites. And while I have a workaround with the static IP address, I was still trying to figure out the cause of this problem.

Then the other day I noticed something which seemed so obvious I wondered why I hadn't noticed it before, and whether I still had a brain at all. The Asus has two adapters, a wired LAN adapter at eth0, and a WiFi adapter at ath0. The messages I was getting when I tried to start the WiFi adapter were about "DHCPDISCOVER on eth0". Since eth0 was not plugged in at the time, it was obvious that it would never be getting a response from the DHCP server. The new question, however, is why is dhclient requesting the DHCPDISCOVER on eth0 when I am trying to start ath0?

I have read dozens of posts on numerous sites and no one seems to have addressed this particular question, although from looking at what is posted I believe others are having the same experience. So my question is, why would the DHCPDISCOVER request be going out on a different adapter than the one I am trying to start, and why would this only be happening when I am at home?

blackhole54 09-29-2008 02:33 AM

See if this helps:

All times are GMT -5. The time now is 07:19 PM.