-   Linux - Wireless Networking (
-   -   dhcp no ip address and netmask dont match route address (

pengy666 05-07-2005 05:16 PM

dhcp no ip address and netmask dont match route address
OK so i a newbie like many people here and i trying to get internet working in suse 9.1 personal, i tried my wireless lan first (as i have a wirelees router/modem) but i just couldn't get ndiswrapper to work , so i just enabled on board lan! i got the card found and a module(driver) working i think!

i had a good read around here and i got some good tips from some peoples "similar" problems and i've made a little bit of progress but i keep getting

dhcp no ip address signed .....backgrounding ? wtf?

havent a clue why so i messed around as you probably shouldnt and this is what i did

tux2:~ # ifup eth0
eth0 device: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 91)
eth0 configuration: eth-id-ff:ff:ff:ff:ff:ff
DHCP client is already running on eth0
Warning: interface eth-bus-pci-0000:00:0c.0 is not (yet?) active.
Warning: interface eth-bus-pci-0000:00:0c.0 is not (yet?) active.
Warning: No interface active (yet?)

so i aint worried about eth-bus-pci thats my wlan0 i cant sort out

so i just kept tinkering away i did this

tux2:~ # ifconfig
eth0 Link encap:Ethernet HWaddr FF:FF:FF:FF:FF:FF
inet6 addr: fe80::fdff:ffff:feff:ffff/64 Scope:Link
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1299 (1.2 Kb) TX bytes:27730 (27.0 Kb)
Interrupt:10 Base address:0xd800
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:246 errors:0 dropped:0 overruns:0 frame:0
TX packets:246 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:17892 (17.4 Kb) TX bytes:17892 (17.4 Kb)

so i just trying all sorts now to try and get internet???

so i did more tinkering after checking on this forum

right i thought armed with more commands than i really understand so i did this

which seemed to get me more progress konquerer at least looked for something for a few minutes this time

tux2:~ # ifconfig eth0 netmask up
tux2:~ # route add default gw eth0
tux2:~ # route add -net netmask
route: netmask doesn't match route address
Usage: route [-nNvee] [-FC] [<AF>] List kernel routing tables
route [-v] [-FC] {add|del|flush} ... Modify routing table for AF.

route {-h|--help} [<AF>] Detailed usage syntax for specified
route {-V|--version} Display version/author and exit.

-v, --verbose be verbose
-n, --numeric don't resolve names
-e, --extend display other/more information
-F, --fib display Forwarding Information Base (default)
-C, --cache display routing cache instead of FIB

<AF>=Use '-A <af>' or '--<af>'; default: inet
List of possible address families (which support routing):
inet (DARPA Internet) inet6 (IPv6) ax25 (AMPR AX.25)
netrom (AMPR NET/ROM) ipx (Novell IPX) ddp (Appletalk DDP)
x25 (CCITT X.25)
what that all about? so i did this

tux2:~ # netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface U 0 0 0 eth0 U 0 0 0 lo UG 0 0 0 eth0

so can anyone help dechiper this and explain to me what i'm doing wrong?

i have tried yast but nothing seems to work in yast so i'm just trying to establish a connection to something!!

before i did these last ip assignments if i did a ping to router i just got "network unreachable"
after doing these i get no response so i feel i did something but aint sure what is right? i'm sure its to do with dhcp not having an ip address?

thanks in advance from a newbie


pengy666 05-08-2005 09:33 AM

wel i just decided to try red hat not used it yet and suse personal aint got a fatlot with it! hopefully i can sort it out

All times are GMT -5. The time now is 03:06 AM.