-   Linux - Wireless Networking (
-   -   device not present (

master 05-23-2004 05:43 PM

device not present
hello iv just installed redhat 9 iv allso installed the driver for my ethernet which is a bcm400 any way what i would like to know is when i go in to network config it shows i have installed bcm400 but when i click "save" it says "bcm400 device eth0 does not seem to be present"now befor i installed driver. bcm400 was not present so why do i get this messge it must be installed or i would not see it in my listcan any 1 help

winsnomore 05-23-2004 07:16 PM

What does lsmod reporrt ?

Also .. check the output of the installmessage .. I think by dmseg and see why ethernet failed.

what does ifconfig report ?

master 05-24-2004 01:09 PM

hello me again ok i typed
"ifconfig" feedback was link encap:local loopback
inet addr: mask:
up loopback running mtu:16436 metric:1
rx packets:697 errors:0 dropped:0 overuns:0 frame:0
tx packets:697 errors:0 dropped:0 overuns:0 carrier:0
collisions:0 txqueuielen:0
rxbytes:47090 (45.9 kb) txbytes:47090 (45.9 kb)

now i know mask is wrong but when i go into internet connection then edit
it shows the correct numbers
allso i typed "dmseg" command not found
i was root user when i did this

winsnomore 05-24-2004 01:24 PM

It appears you don't have eth0 port .. you are only getting the loopback port info from ifconfig.
please check with lsmod .. what module (driver) is loaded for ethernet
see what that says about an ethernet device.

Try going through the dmseg .. by
dmseg | more
dmsget | grep eth

see what the output is .. it should give you a clue if it ever went into detecting the card.

There is huge thread of broadcom driver bcm400 .. seems like it's an ongoing issue you might want to read that.

Possible tries .. disable ethernet from bios (i assume it's built in the motherboard) .. reboot .. kudzu will remove the drivers.

Disable PNP from bios .. enable Ethernet .. reboot ... hopefully you will have better luck with that.

master 05-24-2004 01:55 PM

ok i typed "lspci"
it was a big list but to keep it short for ethernet it said
00:0f.0 ethernet controller:broadcom corp bcm4401 loosebase-T(rev 01)
ok i typed "lsmod" now i could not see anything to do with ethernet

master 05-24-2004 03:31 PM

hello is there another way to get eth0

master 05-25-2004 03:12 PM

i went in to my bios but could not see anything for my ethernet can u give me a clue

master 05-25-2004 03:17 PM

ok i typed "dmsget | grep eth" but it said command not found i allso tried
"dmseg | more" command not found
now i allso typed in "rmmod"and it said "module bcm4400 is not loaded"
if any 1 can assist me any further i would appreciate it

Ironica 05-25-2004 04:03 PM

That should be dmesg (not dmseg), a typo I guess.
I think you will need to have:
alias eth0 bcm4400
in your /etc/modules.conf. Once the module is loaded, you need to type:
ifconfig eth0 up

master 05-25-2004 04:59 PM

ok i went in to the directory "/etc/modules.conf" and alias bcm4400 was there does that mean it is loaded? i then opend a terminal as root typed "ifconfig eth0 up" the feedback was
"unknown interface no such device"

Ironica 05-25-2004 05:40 PM

Sorry, to load the module, the command is:
modprobe bcm4400
If modprobe can't locate the module, you can use insmod to install it. Once it's successfully loaded, it will appear in the output from lsmod.

master 05-26-2004 03:17 PM

hello ironica
i typed as root "modprobe bcm4400" the feedback was
"cant locate module bcm4400"
i then typed "insmod bcm4400" the feedback was no "module by that name found"
anymore ideas ?

master 05-27-2004 12:12 PM

come on folks im in need of guideance please

master 05-27-2004 04:21 PM

hello it me again iv cracked it i just want to say thank you to every 1 who helped i dont know why but when i turned my comp off and back on kudzu detected my nic and i was away

master 06-27-2004 01:58 PM

hello again it it would seem not everything is as straight forward as i would like i was using my linux system yesterday i closed it down went on to windows then when i tried to return to linux up and behold once again i got the error message "bcm4400 device eth0 not present"
when i type" modprobe bcm4400" feedback=cant locate module bcm4400"
when i type "insmod bcm4400" feedback=no module by that name found"
when i type "rmmod" feedback=module bcm4400 is not loaded"
when i type "lspci" feeedback=00:0 ethernet controller:broadcom corporation bcm4401 100 base-t(rev01)
allso when i go in to the file /etc/modules.conf "alias eth0 bcm4400" is thereonce again i would appreciate as much help as i can get thanks

All times are GMT -5. The time now is 09:34 AM.