LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Dell Wireless 1397 (BCM4312) and creating interfaces (https://www.linuxquestions.org/questions/linux-wireless-networking-41/dell-wireless-1397-bcm4312-and-creating-interfaces-725011/)

jamescondron 05-10-2009 12:23 PM

Dell Wireless 1397 (BCM4312) and creating interfaces
 
Yep, its another one of those horrible 'My Wireless card doesn't work WTF!!' type posts.

The machine is a Dell Inspiron 1545 with a Dell Wireless 1397 card (BCM4312 chipset for those keeping count). I've checked the sensible stuff; its happy enough with lspci:

Code:

root@jcnew:~# lspci -vvv
<..>
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
        Subsystem: Dell Wireless 1397 WLAN Mini-Card
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 4
        Region 0: Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
        Capabilities: [58] Vendor Specific Information <?>
        Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [d0] Express (v1) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <64us
                        ClockPM+ Suprise- LLActRep- BwNot-
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [13c] Virtual Channel <?>
        Capabilities: [160] Device Serial Number 24-00-3d-ff-ff-2c-3e-ea
        Capabilities: [16c] Power Budgeting <?>

dmesg is happy it exists and that the driver is loaded

Code:

root@jcnew:~# dmesg|grep Firmware
[  15.800367] Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]

- Just to show this in another light;

Code:

root@jcnew:~# lsmod|grep b43
b43                  110748  0
ssb                    33476  1 b43
rfkill                  5652  1 b43
pcmcia                29548  2 b43,ssb
firmware_class          6816  2 b43,pcmcia
rng_core                3940  1 b43
mac80211              139712  1 b43
led_class              3908  1 b43
input_polldev          3752  1 b43
pcmcia_core            31892  3 b43,ssb,pcmcia

yet it doesn't appear in ifconfig;

Code:

root@jcnew:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:23:ae:31:d7:68 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18

eth0:avahi Link encap:Ethernet  HWaddr 00:23:ae:31:d7:68 
          inet addr:169.254.7.119  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:18

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:718 (718.0 B)  TX bytes:718 (718.0 B)

I'm very confident the rfkill switch isn't on (off?)- I mean, that the device is powered on, I shouldn't imagine it'd be in lspci if it was, though if anyone knows better, then awesome. Incidentally, if I hit the wireless switch I get a different issue in dmesg:

Code:

root@jcnew:~# dmesg|tail -2
[ 1525.019084] atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
[ 1525.019084] atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.

but as I say, I've confident the thing is on.

Basically, I think I just need to create a new interface, and give it the hardware location from lspci but not only have I never had to do this, I don't really know what I should be searching for to do it- even in gentoo I never had to do this, that was a case of simply copying network scripts.

Any thoughts anyone? I'm really stuck here, and I don't really want to give up either, its pretty important (to me at least) that this gets resolved

Hangdog42 05-10-2009 04:28 PM

A couple things to consider:

It may not show up in ifconfig if it hasn't been configured and brought up. However, it should be showing in iwconfig no matter what state it is in. Also have a look and see if Network Manager can see the thing.

Also, you may consider using Broadcom's Linux driver since it does support the 4312. My experience is that it works better than b43. I know Ubuntu has it in it's restricted drivers repository.

business_kid 05-16-2009 07:09 AM

Been here. Try this in /etc/modprobe.d/wlan0

install b43 /sbin/modprobe -i ssb; /sbin/modprobe -i b43; /sbin/modprobe -i btusb
install btusb /sbin/modprobe -i ssb; /sbin/modprobe -i b43; /sbin/modprobe -i btusb

This is clumsy and can be improved on. If it gives you
1. ssb
2. b43
3. btusb

see if that fixes it

jamescondron 05-23-2009 05:12 AM

Comparatively old post, but just to finish it up for people searching for solutions to the same problem: http://linuxwireless.org/en/users/Dr...nownPCIdevices tells us that the particular card I have is unsupported, so without some quick hacks (Since none of the above worked for me, that is) I went with what all good sysadmins do in my position; I gave up and installed a different card instead- the IWL3945, easy peasy, straight out the box, quick firmware download.

coolinout61 01-21-2019 06:45 PM

still unsupported?
 
know this is an old notebook, but hoping that this card is now supported in the latest slackware distro. tried to go into /etc/modprobe.d/wlan0, but 'no such file or directory' is the reply. any help would be appreciated. have installed the latest driver, correct arch. same problem as above, but driver is loaded as above.

thanks,
colin

never mind, found the answer in dmsg|grep b43


All times are GMT -5. The time now is 12:48 PM.