-   Linux - Wireless Networking (
-   -   Dell Wireles 1470 Dual Band help (

blazted 05-09-2006 03:15 PM

Dell Wireles 1470 Dual Band help
I have a Dell Lattitude 410 with a built in 1470 Dual band WLAN PCI card built in. I have it dual boot with XP and Ubuntu. In Ubuntu I cannot get the OS to see the card at all. When i run ifconfig It does not come up at all. The only interface I see if eth0 and my loopback. How do I manually install this?

Hangdog42 05-11-2006 07:00 AM

Support for the card really depends upon what chipset that card uses. I did a little Googling, and it seems that card uses a Broadcom chipset, which means your best bet is to use the Windows drivers with ndiswrapper. If you are feeling really adventerous, there is a native linux driver for that card, but it currently involves patching and compiling your own kernel. I wouldn't advise it unless you are comfortable doing both.

chargerbear 06-25-2006 11:59 AM

Dell Wireless 1470
If you have installed Dapper Drake from the ISO CD or upgraded from Breezy Badger to Dapper Drake and you would like to use ndiswrapper for your broadcom 43xx wireless card , you'll need to disable the bcm43xx driver by running:

echo 'blacklist bcm43xx' | sudo tee -a /etc/modprobe.d/blacklist

You can copy and paste this into your root terminal from this post. I never make typing errors when I do this. This will ensure that the bcm43xx driver doesn't load at startup and will therefore not conflict with ndiswrapper.

Reboot your computer.

The next step is to find out if you have the ndiswrapper package installed. If you upgraded from Breezy you probably do, if you installed Dapper from the CD you probably don't. Open Synaptic Package Manager and search for ndiswrapper. Install if need be.

Then you will need the driver. I got mine from my windows installation. I got this computer from my daughter for father's day and wanted to get my WLAN going, so I didn't have my windows partition visible to Dapper yet. I did a windows search for bcmwl5.inf and copied it to a CDRW. If you don't have Windows you can Google Dell Wireless 1470 Dual Band WLAN driver. Put it in a new folder of your choice if you download it. When you unzip the EXE it makes a mess.

Now the easy part. Open your root terminal type
ndiswrapper -i (Driver file)
Mine looked like this:

ndiswrapper -i /media/cdrom/bcmwl5.inf
ndiswrapper -l
ndiswrapper -m

Reboot your computer and your in business. When Dapper comes back up unplug your Ethernet cable and go surfing.

I hope this gets you guys going faster then me. It took me a day and a half to figure this crap out. My other laptop was an IBM Thinkpad and the WLAN just worked. This is the first time using ndiswrapper for me. I tried to use the 43xx program first. I failed miserably with that. Ended up reinstalling Dapper.


All times are GMT -5. The time now is 01:02 AM.