-   Linux - Wireless Networking (
-   -   Connects to router, but no internet (

Lee_B_H 01-15-2004 11:14 PM

Connects to router, but no internet
I just got a new laptop and I'm trying to connect to the internet through my linksys wireless router. Ok, here's the deal. I have SuSE Linux 9.0 and Windows XP Home on this machine. I can browse the internet no problem with XP running. I can't get Linux to do it though. Here's the strange thing. I can connect to the router and change settings, but I can't get anything on the net. No updates, no pings, no browser. Nothing connects. Kwifi manager shows that I have a good connection and I have an IP. My old laptop worked fine with the same wireless card and the same version of Linux. The old laptop is wired up and acting as a server now. I can Secure Shell (within my network) to it from the new laptop and ping out and I ran an irc client with no problem. I can connect to a neighbor's wireless network and I can't get to the internet through Linux there either. I've tried connecting directly to the router with the same problem too. The firmware on the router is current. I imagine there's some kind of package I didn't install that I installed last time, but I can't figure out what it could be. The only thing I think I did different was I installed all the C++ packages. Could there be something in there that would cause it not to connect? Help!

sqn 01-16-2004 12:43 AM

in linux use the <i>route</i> command to tell your computer through where to get on the internet.
Why you see the router? wel it's quite simple: the laptops have an adress in the same class (router IP: and laptop IP: ).
If this fails do the folowing commands and post the results:

# ifconfig
# route -n
# cat /etc/resolv.conf

Lee_B_H 01-25-2004 08:26 PM

problem fixed
I finally got around to working on this after a couple of weeks. First I reinstalled Linux which didn't help. Then I deleted both the wireless card and eth0. I reinstalled eth0 and connected to the router and everything worked fine. I downloaded updates and everything. Then I reinstalled wlan and it didn't work. Then I deleted both and just reinstalled wlan which worked. So now I can browse the net with no problems. Why can't I have both installed at once? What is it doing?

Present 01-08-2005 05:31 PM

not sure. i think the problem is based on route tables. i'm having the same problem. i entered my gateway ip address in yast routing tables which gets ethernet to connect to wan, but wireless is stuck in lan. very bizarre.

i'll check into it and post response here if i find a fix.


Present 01-08-2005 08:54 PM


got it working!

just noticed a post by a Novell Tech tho the response reflects most linux installations i'm sure...

dhcp client sticks on the first nic to make a request (probably ethernet as was my case). here is the fix:

as su (super users: type su at prompt): ifdown eth0 (or your eth nic), ifdown eth1 (or your wireless), then ifup eth1 (your wireless). that should give dhcp client assign rights for your wireless.

tech also had a good suggestion to use different profiles (suse has good support on this) for each config if you are moving between different dhcp servers on eth and wireless.

gl hope it works for you

All times are GMT -5. The time now is 12:46 AM.