-   Linux - Wireless Networking (
-   -   Connecting to Tmobile Using Broadcom/Ndiswrapper (

fortezza 06-17-2006 02:13 PM

Connecting to Tmobile Using Broadcom/Ndiswrapper
I have Fedora Core 5, and Broadcomm WiFi card using NDIS drivers. The card works fine at home using WEP and WPA, so I took it to Starbucks and tried to connect to their tmobile Wlan.

First I turned off iptables firewall and bluetooth services. Then I killed the wpa_supplicant process.

THen I shutdown the wlan interface using "/sbin/ifdown wlan0"

Next I copied my working ifcfg-wlan0 config to a back up copy, and then edited the copy to delete the WEP key, change the SSID to tmobile, and I deleted the "CHANNEL=11" line.

Next I brought up the wlan0 interface using the command "/sbin/ifup wlan0". Then I checked the interface configuration using ifconfig wlan0"

Unfortunately I did not save the output, but the IP address for the wlan card was 10.254.x.x, which I tried to ping. The ping command responded that I could not ping a broadcast address. In addition, I check my resolve.conf file, and saw that it had been updated by tmobile's dhcp service because the settings were nothing like what my home WiFi network DHCP server is configured to hand out.

So, I think the only problem is that my card is not getting a valid IP address from Tmobile's DHCP server. I tried release and re-requesting the DHCP information using "dhclient -r" and then "dhclient wlan0" commands, but I keep getting the same results.

Unfortunately, the local Starbucks staff are clueless about the Tmobile service, so I am on my own here. Any ideas on what I can do to fix this?

fortezza 06-17-2006 07:22 PM

Additional Information and a Question
It looks like problems similar to mine can sometimes be solved by using various DHCP clients. Right now I have dhclient, but it looks like DHCPCD might be better for wireless networks. If no one else has an idea, I will try that out at Starbucks to see if it fixes my IP address problem. Another client I have heard about is called 'pump', but it is mostly in older posts so it may have been abandoned by the developer.

A second question is if there is a recommended way to create a script that brings up the Wireless connection on demand, allowing you to have multiple configurations for home,work, and Starbucks :) What I have so far is create multiple ifcfg files, one per wireless network, and I have made a script for my home networks called . It runs fine as root, but I would like it to be runnable by joe user ( me ) using something like sudo or suid. One thing I cannot do is have it start automatically at work as it would trip the wireless intrusion alarms as I am not authorized to use it there. It takes the security folk about 5 minutes to show up at the desk of someone with an unauthorized wireless connection after they turn it on, lol. I don't want that kind of attention. No thank you.

Any ideas for my original question or for the additional one would be much appreciated.

fortezza 06-17-2006 08:01 PM

Ok, I got an answer via PM for the second part. Using sudo I gave my joe user account to run all of the scripts to start the wlan0 card with the appropriate settings. Also, I compiled and tested dhcpcd client with my home network and it works.

However, this sparked another question: How do a configure linux to use the dhcpcd command instead of dhclient? My ifcfg-wlan0 card just says "BOOTPROTO=dhcp", but there must be a config file somewhere that tell the system how to place a dhcp request. Any ideas?

All times are GMT -5. The time now is 11:50 AM.