LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   connect to internet w/ dhcp but don't know route info (https://www.linuxquestions.org/questions/linux-wireless-networking-41/connect-to-internet-w-dhcp-but-dont-know-route-info-366391/)

towsonu2003 09-23-2005 07:55 PM

CANNOT connect to internet w/ dhcp BECAUSE(?) don't know route info
 
Hi
I am trying to connect to internet thru a wireless accesspoint that uses no keys (open access). I do not have any info about this wireless access point but its ESSID. I am using Slackware 10.2 kernel 2.6.13 ndiswrapper drivers.

Here is my stupid question: how do you connect to internet when you do not know ANYTHING about the accesspoint except its ESSID? I mean, in windows, you just click ont the accesspoint and it connects... how do you do that in linux?

I could not use Kwifimanager. It doesn't do anything but show the access points' names.

Also,

following are the commands I use:

#ifconfig wlan0 up
#iwlist wlan0 scan
# iwconfig wlan0 essid "essid"
#dhcpcd wlan0

it connects to the accesspoint but browsers cannot connect to internet.

thanks

PS. I have a broadcom so I can't use kismet to find the addressing scheme, nameserver etc. (and I'm not sure whether that would help)
PS2. wifi-radar resulted in the same problem as well.

J_K9 09-24-2005 01:29 PM

Those commands look correct - although making a script to do it for you could come in handy... ;)

Have you tried setting your browser to automatically configure proxy settings? Sometimes (if the AP is using a proxy) that will allow it to work. In Firefox, that's in: "General->Connection Settings...->Auto-detect proxy settings blah blah". If that doesn't work, then try switching it back to the "Directly connected to internet" option. :D

M. ;)

Ps. Why have you got an unsecured wireless network?! *tut tuts* :P

towsonu2003 09-24-2005 02:08 PM

Changing the browser settings did not help. Here is some output (this is when I am connected, but the browser does not know):
------------
cat /etc/resolv.conf
nameserver 192.168.0.1
------------
ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:460 errors:0 dropped:0 overruns:0 frame:0
TX packets:460 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:34916 (34.0 Kb) TX bytes:34916 (34.0 Kb)

wlan0 Link encap:Ethernet HWaddr 00:90:4B:4F:EC:67
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::290:4bff:fe4f:ec67/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:100 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:32878 (32.1 Kb) TX bytes:2646 (2.5 Kb)
Memory:d0200000-d0201fff
---------------
iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11g ESSID:"essid" Nickname:"MOVINGSYSTEM"
Mode:Managed Frequency:2.437 GHz Access Point: 00:11:95:0A:98:34
Bit Rate=36 Mb/s Tx-Power:25 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:99/100 Signal level:-84 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:28 Invalid misc:6699 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.
------------------
please help, I am so close and I WANT to see this linux on the internet for once... desperately...

towsonu2003 10-01-2005 01:56 AM

any ideas?

towsonu2003 10-13-2005 08:06 PM

using
sudo iwconfig wlan0 up
dhclient wlan0

after setting the essid worked fine in Ubuntu 5.04-

short101 10-13-2005 08:51 PM

you look like you are connected. so do 'ping 192.168.0.1' thats your ap. if you can ping that, then try 'ping 66.102.7.99' if that works try 'ping www.google.com' and if that fails, then its your resolv.conf. you need to find a dns to put in your resolv.conf. (even though the adress in there should work..)


All times are GMT -5. The time now is 06:39 PM.