-   Linux - Wireless Networking (
-   -   Cannot set ESSID with iwconfig (

leapingfrog 07-09-2004 01:51 AM

Cannot set ESSID with iwconfig
Hello Guys,

I have a Dell 600m laptop with an Intel Centrino 2100 wireless card. I successfully compiled ndiswrapper and was able to get the wireless card detected and "running" in linux (as far as the driver goes).

However, when it comes to configuring my card for my wirless network, I *cannot* get iwconfig to set my SSID! Everything else works... changing channels, setting up the WEP key, etc, but not the SSID!

Here is the command I'm running:

iwconfig wlan0 essid "Neptune"
I've also tried it without quotes and with several other network names... nothing.

Everytime I type:


iwconfig wlan0
I see:

wlan0 IEEE 802.11b ESSID:""
Mode:Managed Frequency:2.412GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:54Mb/s
RTS thr:1600 B Fragment thr:2344 B
Encryption key:8384-1E3F-03B9-7EA4-08F9-xxxx-xx Security mode:restricted
Power Management:off
Link Quality:0/100 Signal level:-98 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

What am I doing wrong?

I am on Fedora Core 2 with 2.6.5-1.358 as my kernel (whatever comes with FC2).


Also - I've tried to change settings with the card both up (ifconfig wlan0 up) and down, and still nothing... I'm doing all of the commands with the root accont (su -).

dissolved soul 07-09-2004 01:55 AM

it says link quality 0/100
i would be more worried about that at the moment

what wireless router do you have?

leapingfrog 07-09-2004 02:02 AM

Thanks for the quick response. I have a Linksys BEFW11S4 router.

leapingfrog 07-09-2004 02:42 AM

I just found this...... seems like a common problem :( Now where is the solution?!

Hangdog42 07-09-2004 08:04 AM

I've seen a couple of examples of cards not being able to set the SSID unless the router was broadcasting it. If your router isn't broadcasting the SSID, you might try turning that on and see if it helps.

pibby 07-09-2004 08:28 AM

I don't think that you need quotes around your ESSID, for instance mine is set like this:

iwconfig wlan0 essid RAGEKAGE

Try that and see if it works :)

dissolved soul 07-09-2004 10:19 AM


Originally posted by leapingfrog
Thanks for the quick response. I have a Linksys BEFW11S4 router.
i have that exact same router with my current wireless linux setup.
for now, i just have it on the default settings and it works fine. i was playing with the settings, and had turned SSID broadcast off (just to see if the laptop would still work), restarted the computer, and it didn't work. it couldn't find anything (even if i specified correct the ssid on the laptop).. as soon as i turned ssid broadcast back on it worked fine.

dinojerm 07-09-2004 12:53 PM

I am also having a similar problem with being unable to set the essid (and the access point MAC).
I'm using a Belkin 802.11G PCI card (f5d7000) through ndiswrapper and a Belkin 802.11B router. I do have "Broadcast SSID'" enabled in the router configuration.
I'm running Mandrake 10, with the default 2.6.3-7 kernel.
Here is the output of "iwconfig wlan0" (after setting the encryption key)

wlan0    IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.462GHz  Access Point: FF:FF:FF:FF:FF:FF
          Bit Rate:54Mb/s  Tx-Power:14 dBm
          RTS thr:2347 B  Fragment thr:2346 B
          Encryption key:C483-51C4-97FF-FFCF-CC99-EE9E-DA  Security mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-10 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:25897  Missed beacon:0

According to this page, the SSID will show correctly when the device is up, but this did not fix the problem for me.

1kyle 07-10-2004 10:17 AM

It's usually easy to edit the etc /sysconfig/network file. Find the entry for wlan0 or whatever the one you are using is.

Incidentally set the network card from the config panel -- you need to set the ip address, dsn servers, and gateway just like with a normal network card as well. I'm doing mine manually since I don't have a DHCP server. Once you've set these then when you do IWCONFIG you'll find the stuff already set.

stuart 07-10-2004 02:58 PM

im having the exact same issue guys, i have no wep key set on my AP(for testing purposes that is) and it works fine with windows but when i get into linux it seems to not work,

iwconfig brings this

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:54Mb/s Tx-Power:16 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

i have link quality 100 as my AP is right next to the laptop at the moment, but no matter what i do i cant change the ESSID, im using mandrake 10 official with ndiswrapper 8.0 to get my card running. its a belkin AP. same as you guys i set the essid "iwconfig wlan0 essid "idhere" and it appears to set it but it doesnt work :(

i hope we can work out a fix for this, where is the file to set the settings in manually? im a pretty linux nook and dont know where to look for it

i dunno if this helps, but when i run dhcpcd i get this

[root@home stu]# dhcpcd.exe: interface eth0 has been configured with old IP=
dhcpcd wlan0
[root@home stu]# /etc/dhcpc/dhcpcd.exe: line 27: .: filename argument required
.: usage: . filename

zorba4 07-10-2004 05:47 PM

@dinojerm : how did you manage make your Belkin atapter work with Mandrake 10? Did you have to pick a driver from the net and compile it ? Or is a driver embedded with the Mandrake10 distro ?

dinojerm 07-10-2004 10:15 PM

I used NdisWrapper . It lets you use (some) wireless adapters with their windows drivers. Mandrake 10 does come with a version of it, but it is only version 0.4. I uninstalled it and installed 0.8 from the source (You will also need to install the kernel source to install it). You will also need the .inf and the .sys driver files, available from the cd that came with the card. It should be compatible with the f5d7000 (except for this problem).

peekho 07-10-2004 11:38 PM

Hey guys,
I had noticed a similar problem with the essid, i'm using slackware 10.0 and NDISwrapper. I noticed that if you don't set the encryption key first then you won't be able to connect to the network.

stuart 07-11-2004 04:02 AM

so has anyone had any luck fixinf this problem yet?

stuart 07-11-2004 06:40 AM


I was having the exact same trouble as you guys, i was using ndiswrapper 0.8 on my asus laptop which has an asus wireless card that uses the broadcom BCM94306 chipset. I went to the ndiswrapper site, and on their site they had two links to drivers for my chipset there so i got them and thats what i was using, the card would detect ok, and it would get signal to the AP but nothing else, i coudnt change anything like ESSID or when i tried to run dhcpcd it would give me errors, anyways the reason i didnt use the driver that came with my card was that it was in a windows installer package and i didnt know what to get from the installed windows sytem to use with the linux install. I was looking in my program files folder and noticed an asus folder there so i had a look and it had drivers for my card for win98, winME, win2k and winXP. I tried the XP one but it seemed to do nothing so i had a look at the inf and it was all garbled data and i couldnt read it in anythign in linux so i had a look at the ME/98 drivers and they were fine so i tried to install one of those and VOILA!! on next reboot my card detected my AP and here i am typing this over my wireless link.

It was the same named file that i got from the ndiswrapper site(bcmwl5a.inf), just the contents of mine were slightly different

The laptop is the ASUS L5000GA

So to summarise

Ndiswrapper 0.8 with Broadcom BCM94306 chipset and the generic driver that comes from the ndiswrapper site for that chipset did not work for me and i had to use the driver that came with my card(which i didnt do in the first place because i couldnt find it)

I hope this info can help you guys out, and maybe you can try some different driver files and see if they work?? (you didnt post wether you were using the windows driver that came with your card or if you were using one from ndiswrapper site)

All times are GMT -5. The time now is 08:30 AM.