LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 09-28-2005, 08:14 AM   #1
matSA289
LQ Newbie
 
Registered: Sep 2005
Location: London
Distribution: suse
Posts: 10

Rep: Reputation: 0
cannot get intersil prism to work in SUSE 9.3


Hi

I have recentlt been trying out Linux and have used a few distros.
I have a Medion laptop MD 41567 with a built in Intersil Prism wireless card.
When I tried Mepis it it recognized the card and functioned well on booting from CD. I did not need to configure anything

But when trying Suse 9.3 it recognises the card but doesn't find a signal.
Signal is fine as it still works in Windows and Mepis. I tried ndiswrapper but it fails

Please help. ????can I copythe driver from Mepis to Suse

Me Mat
 
Old 10-01-2005, 01:03 AM   #2
shuuhen
Member
 
Registered: Jun 2004
Distribution: Mac OS X 10.6.6, Gentoo Linux, FreeBSD 6.0
Posts: 127

Rep: Reputation: 20
You will probably have to download the linux-wlan drivers or the HostAP drivers. I personally prefer the second, because the HostAP drivers use the standard wireless utilities while the linux-wlan drivers have their own special setup (standard utilities are a lot easier).

As far as moving the driver from MEPIS to SuSE, I'd have to say no. If they were running the exact same kernel version and configuration, then you would be able to, but I doubt that is the case.

The output from lspci might help some here.
 
Old 10-01-2005, 11:03 AM   #3
matSA289
LQ Newbie
 
Registered: Sep 2005
Location: London
Distribution: suse
Posts: 10

Original Poster
Rep: Reputation: 0
Hi

Thus far I have found a few drivers for pciid 260:3890 on sourceforge. I have no problem running ndiswrapper and the command 'ndiswrapper -l' returns 'driver present harware present' for a few drivers. I have tried my own driver on the CD that came along as well.

depmod -a gives no errors but modprobe ndiswrapper returns the same message each time

' FATAL: error inserting ndiswrapper (/lib/modules/2.6.11-4-21.7-smp/extra/ndiswrapper.ko) : operation not permitted'

I have tried a few drivers all give the same message.

Any help from this point would be appreciated

Thanks
 
Old 10-01-2005, 08:25 PM   #4
shuuhen
Member
 
Registered: Jun 2004
Distribution: Mac OS X 10.6.6, Gentoo Linux, FreeBSD 6.0
Posts: 127

Rep: Reputation: 20
Are you running the commands as root? Running those commands as your regular user would probably be the reason for the error. If you are running the commands as root, check what the permissions are on /lib/modules/2.6.11-4-21.7-smp/extra/ndiswrapper.ko. I'd expect something like -rw-r--r-- with root as both owner and group.
 
Old 10-15-2005, 08:57 AM   #5
matSA289
LQ Newbie
 
Registered: Sep 2005
Location: London
Distribution: suse
Posts: 10

Original Poster
Rep: Reputation: 0
got ndiswrapper working

Hi

I have finally sorted out my wirless card. The error message it seems arose from use of 2 installations of ndiswrapper. I was unaware that it was installed off the Suse 9.3 DVD which I got from a magazine.
I had been downloading and installing ndiswrapper from sourceforge but didn't need to.

Now using it is straightforward in Suse 9.3. I have used the windows XP driver that came with my card and I think this is the same as the one recommended on http://ndiswrapper.sourceforge.net/m...index.php/List

Now the rest I configured using Yast. These instructions are found on
http://www.angelfire.com/linux/hardwire/wireless.html

Thanks for help so far and the forum has been most useful.

Meeeeeeeee
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no wireless suse Intersil Prism 2.5 leandean Linux - Wireless Networking 10 10-26-2005 11:23 PM
Intersil Prism Javelin WLAN problems Heliode Linux - Wireless Networking 7 05-05-2005 09:18 PM
ma111 wireless card + prism 2 driver + SuSE 9.1 pro !!!HELP!! catmandu123 Linux - Wireless Networking 6 10-09-2004 02:44 AM
MICROSTAR (MEDION 2804) Notebook Prism 2.5 and Suse 9.1 n00bguide? major(nwo) Linux - Wireless Networking 0 07-27-2004 04:02 PM
LinkSys WMP11 Prism 2.5 install in SuSE SkittlesLA Linux - Wireless Networking 3 01-27-2004 11:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration