-   Linux - Wireless Networking (
-   -   cannot connect to WPA2 network after modifying network connections (

gregnorc 05-14-2010 08:56 PM

cannot connect to WPA2 network after modifying network connections
So I'm running 10.04, and my wireless card is a 8191SEVA2

I had been having trouble at work with the connection - basically, it was connection to a very weak AP instead of a much stronger one... they both had the same SSID but different mac addresses.

So I edited network connections, and made a custom connection that specifically specified the BSSID of the router with the strong signal, and all was well.

Then I came home, and was unable to connect to my home network. I diabled the wifi on my iPhone and logged back in - yup, password I have written down is correct.

Ethernet also works.

I went into network manager, deleted the network I had created (and all others), and restarted networking. Click on the name of my network, enter the pass, and the same thing happens: it just flashes the "loading" animation for 20+ minutes...

I tried reinstalling network-manager, and WPA-supplicant, but that didn't help either.

Anyone have any ideas how I can fix this?

gregnorc 05-14-2010 11:55 PM

So the issue seems to have solved itself... odd.

I'm guessing reinstallation of WPA2supplicant and/or networkmanager did the trick, but can't be positive. I had brought wlan0 up and down multiple times... going to try and reproduce thue issue, if I can I'll post something more detailed for the benefit of everyone...

All times are GMT -5. The time now is 08:52 AM.