-   Linux - Wireless Networking (
-   -   Cannot connect in Ubuntu 10.04 with Ralink 2870 (

MrLove247 05-06-2010 07:09 AM

Cannot connect in Ubuntu 10.04 with Ralink 2870
I'm kind of new to Ubuntu (and linux) and I'm having some problems with my wireless network. It all worked in 9.10, all I needed to do then was to blacklist rt2800usb in blacklist.conf and my wireless worked. But since I upgraded to 10.04 my wireless network hasn't worked.
When I blacklist rt2800usb my wireless connection disappears, but when I remove the blacklist I can see all wifi networks but cannot connect. I have downloaded ralink drivers and changed the supplicant revisions from n to y in

lsusb gives:
Bus 001 Device 003: ID 07d1:3c09 D-Link System DWA-140 802.11n Adapter [ralink rt2870]

iwconfig gives:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Moshu"
Mode:Managed Frequency:2.422 GHz Access Point: Not-Associated
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

all help is appreciated

MrLove247 05-07-2010 03:06 PM

I found a solution at

but needed to add rt2800usb to blacklist in order to make it work.

sudo gedit /etc/modprobe.d/blacklist.conf

add the line
blacklist rt2800usb

All times are GMT -5. The time now is 05:09 PM.