-   Linux - Wireless Networking (
-   -   Can connect to wifi networks but no internet (

abibibo 10-13-2007 04:04 PM

Can connect to wifi networks but no internet
I've been running into this problem on Fedora 7 after installing rtorrent and opening ports on the "firewall & SELinux" menu (though not sure if thats related).

Generally the computer connects to the network at startup and I have internet for about 2 minutes. After 2 minutes I can no longer connect to external web pages.

If I run "ifdown wlan1" followed by "ifup wlan1" I occasionally will get a working connection for ~1minute where I can ping

Running "iwlist wlan1 scan" I can see the available networks and successfully associate with the unsecured networks (I live in a downtown appt. with several wifi hotspots, but done have an internet connection of my own). I'll be able to ping myself at but am unable to ping external websites via either their dns name.

"dhclient wlan1" completes successfully most of the time (though occasionally stalls), but this doesn't correct the problem.

I've read that some of the network manager applets can cause dropped connections, but I don't have any of these applets running.

From windows I can connect to all unsecured networks without any problems.

Anyone got any hints? What commands can I run to give you more info?

Its a Zonet ZEW1602 card (Marvell chipset) configured with ndiswrapper. Running depmod -a and modprobe ndiswrapper doesn't help anything.

Thanks in advance,


abibibo 10-14-2007 01:29 AM

I've switched to a gnome session and the networking stays up without any problems. I'm guessing it might be related to the problems I'm having getting compiz-fusion running smoothly (compiz is only set to auto load on my KDE session). So unless you know off hand what is causing the problem I'd say disregard this post until I get a chance to disable various things in KDE and see what the conflict arises from.



All times are GMT -5. The time now is 03:56 PM.