-   Linux - Wireless Networking (
-   -   Broadcom product: BCM4322 802.11a/b/g/n Wireless LAN Controller help with wireless N (

whatleya 11-20-2009 08:32 PM

Broadcom product: BCM4322 802.11a/b/g/n Wireless LAN Controller help with wireless N
I have a product: BCM4322 802.11a/b/g/n Wireless LAN Controller for my wireless card. I do not know how to get the drivers to use Wireless N any Ideas.
configuration: broadcast=yes driver=r8169 driverversion=2.3LK-NAPI

GrapefruiTgirl 11-20-2009 09:06 PM

Something looks weird.. BCM4322 is a Broadcom device if I'm not mistaken, yet you're telling us that the "driver=r8169" which is a Realtek device driver.

Is the device working at all (I must guess that you are connected using it as we speak? Or if not, what are you connecting with?) or is it only not working in N mode? Sorry, please clarify.

Anyhow, here's a link:

That link is to the Broadcom downloads page where you can get the Broadcom STA driver for Linux, for your Broadcom 4322 device. There are instructions included from that link and/or with the driver download, and there are also several threads on LQ here already wherein people discuss and install this STA driver for cards just like yours, though I cannot recall if any of those previous threads involved Ubuntu (that IS what you're using, yes?). If you are using Ubuntu, I'm not sure if the Ubuntu repositories make this driver available or not, or if you MUST download and install it yourself.

Perhaps an Ubuntu user can provide us more insight.


whatleya 11-21-2009 09:28 PM


I am using Ubuntu Netbook remix. I am not to sure on how to follow the instructions as I tried to but could not get anywhere. It has been ages since ive used linux and im trying to get back into it. I am thinking that not using the right drivers is what is causing alot of my issues that i am having. but thank you for pointing out the difference between the card and the driver

whatleya 11-21-2009 10:52 PM

i tried lowering my mtu to see if it would help me at all

whatleya 11-22-2009 09:41 AM

Well I do believe im connected at Wireless N because looking at my TX rate it is at 104MBPS right now and as far as I know Wireless G can only TX at 54MBPS I will continue to monitor the issue and hope all is well.

Thanks for the help.

All times are GMT -5. The time now is 01:31 PM.