LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Broadcom BCM4312 wireless not working in Debian (https://www.linuxquestions.org/questions/linux-wireless-networking-41/broadcom-bcm4312-wireless-not-working-in-debian-804921/)

jestinjoy 04-29-2010 05:23 AM

Broadcom BCM4312 wireless not working in Debian
 
Hi,

I am not getting wireless in my laptop. I am using Dell vostro 1520, with Debian Lenny Installed. How could I make it working. Kernel version is 2.6.26-1-686

lspci output

Code:

08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

Heard that from 2.6.xx version onwards, support for this driver is included. What should I do? Also I have some questions to ask.....

1) Even if driver is no there, whether lspci shows the the hardaware information with name?


Please help

craigevil 04-29-2010 05:40 AM

The driver is there but you still need the firmware. Take a look at bcm43xx - Debian Wiki - http://wiki.debian.org/bcm43xx

jestinjoy 04-30-2010 01:05 AM

re
 
I tried installing the driver following the instructions in the link given below.

http://forums.debian.net/viewtopic.php?t=7949

But now also its now working either. After installing the outputs are given below.

# lspci


Code:

08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)


# lsmod
After I I executed # modprobe b43

Code:

b43                  110748  0
ssb                    33476  1 b43
rfkill                  5652  1 b43
pcmcia                29548  2 b43,ssb
firmware_class          6816  2 b43,pcmcia
rng_core                3940  1 b43
mac80211              139680  1 b43
cfg80211              21576  1 mac80211
led_class              3908  1 b43
input_polldev          3752  1 b43
pcmcia_core            31892  3 b43,ssb,pcmcia
............................................

# mdoinfo b43

Code:

filename:      /lib/modules/2.6.26-1-686/kernel/drivers/net/wireless/b43/b43.ko
firmware:      FW13
license:        GPL
author:        Michael Buesch
author:        Stefano Brivio
author:        Martin Langer
description:    Broadcom B43 wireless driver
alias:          pcmcia:m02D0c0448f*fn*pfn*pa*pb*pc*pd*
alias:          ssb:v4243id0812rev0D*
alias:          ssb:v4243id0812rev0B*
alias:          ssb:v4243id0812rev0A*
alias:          ssb:v4243id0812rev09*
alias:          ssb:v4243id0812rev07*
alias:          ssb:v4243id0812rev06*
alias:          ssb:v4243id0812rev05*
depends:        pcmcia,mac80211,ssb,input-polldev,pcmcia_core,led-class,rfkill,rng-core,firmware_class
vermagic:      2.6.26-1-686 SMP mod_unload modversions 686
parm:          bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm:          fwpostfix:Postfix for the .fw files to load. (string)
parm:          hwpctl:Enable hardware-side power control (default off) (int)
parm:          nohwcrypt:Disable hardware encryption. (int)
parm:          qos:Enable QOS support (default on) (int)
parm:          btcoex:Enable Bluetooth coexistance (default on) (int)

# ifconfig Its not showing any Wireless drivers

Code:

eth0      Link encap:Ethernet  HWaddr 00:24:e8:aa:a7:2e 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::224:e8ff:feaa:a72e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5567 errors:0 dropped:2320916122 overruns:0 frame:0
          TX packets:6125 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4702180 (4.4 MiB)  TX bytes:973522 (950.7 KiB)
          Interrupt:217 Base address:0x4000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1530 (1.4 KiB)  TX bytes:1530 (1.4 KiB)


Please help

business_kid 05-06-2010 11:15 AM

Have you got "Fast Ethernet Switching" or something similar set in the BIOS?

This disables one nic if the other is set up (to save power). Unset it if you have

XavierP 05-06-2010 11:44 AM

That thread is 4 years old. Why didn't you use the wiki link? I have a Broadcom 4306 card and the wiki instructions have always worked fine for me.

pixellany 05-06-2010 11:47 AM

See the recent thread started by LQ member "kamon".

I wonder if the wiki mentioned above is a comprehensive tutorial including the option of using the windows driver with NDISwrapper? (I would check for myself, but I don't have a horse in this race.)

EDIT: kamon thread here: http://www.linuxquestions.org/questi...-linux-804957/

EricTRA 05-06-2010 11:54 AM

Hello,

This is the thread pixellany is referring to. In the meantime I've found some mentioning that that specific NIC should work with b43 but cannot try it out for myself. I only got it working in the past using NDISwrapper.

Kind regards,

Eric

pixellany 05-06-2010 08:31 PM

And Eric of course is the good samaritan that got kamon up and running......

craigevil 05-06-2010 08:42 PM

Broadcom, b43/ b43legacy devices

The modules using this firmware are
b43 b43legacy
To install the firmware
apt-get install b43-fwcutter
You can confirm you have installed the firmware by checking for the following files

* /lib/firmware/b43/b0g0bsinitvals5.fw
* /lib/firmware/b43/b0g0initvals5.fw
* /lib/firmware/b43/ucode5.fw


The sidux manual has a nice page on how to install the firmware if the computer you are using can't get online.
sidux Manuals - Hardware and Graphics Drivers - http://manual.sidux.com/en/hw-dev-hw...-free-firmware

They even have a nifty script that will tell you if you need firmware and what it is.

pixellany 05-06-2010 08:48 PM

Quote:

Originally Posted by craigevil (Post 3959879)
How is the thread old? The OP was on 04-29-10, 05:23 AM

I think Xavier was referring the thread linked in the OP. It's last post was just over two years ago.

The "kamon" thread is recent.

XavierP 05-07-2010 03:13 AM

Exactly - there are a few commands in the linked thread that are unnecessary and could even introduce unneeded complications.

jestinjoy 05-08-2010 09:57 PM

re
 
Got it working by downloading the precompiled driver from Broadcaom site. Thanks for the help.


All times are GMT -5. The time now is 05:40 PM.