-   Linux - Wireless Networking (
-   -   bluez hciconfig doesn't list the device class (

ebinjose 01-27-2009 03:40 AM

bluez hciconfig doesn't list the device class

I am using, bluez*3.7.

{Just to give a background:
We are trying to build/run bluetooth stack on an imx.31 (arm based) platform which runs linux.
bluetooth chip is connected to imx.31 platform via a serial port.
I am trying to connect imx.31 to a sony-ericsson mobile handset.}

1) "hciconfig -a", will list all the details of the connected device, like the device class, services, device local name etc. But in our case, it doesn't seem to list such details.
It shows as follows (hcidump is enabled, so there are more messages)
mx31# hciconfig -a
hci0: Type: UART
BD Address: 00:02:5B:00:A5:A5 ACL MTU: 310:10 SCO MTU: 64:8
RX bytes:573 acl:0 sco:0 events:12 errors:0
TX bytes:254 acl:0 sco:0 commands:13 errors:0
Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy:
< HCI Command: Read Local Name (0x03|0x0014) plen 0
Name: 'CSR - bc4'
> HCI Event: Command Complete (0x0e) plen 252
< HCI Command: Read Class of Device (0x03|0x0023) plen 0
Class: 0x000000
Service Classes: Unspecified
Device Class: Miscellaneous,
> HCI Event: Command Complete (0x0e) plen 7
< HCI Command: Read Local Version Information (0x04|0x0001) plen 0
HCI Ver: 2.0 (0x3) HCI Rev: 0xc5c LMP Ver: 2.0 (0x3) LMP Subver: 0xc5c
Manufacturer: Cambridge Silicon Radio (10)

> HCI Event: Command Complete (0x0e) plen 12
2) I tried setting the device class (that I found in /etc/bluetooth/hcid.conf) as "0x3e0100" using
mx31#hciconf -a hci0 device "0x3e0100"
Then the device class was listed properly but later PIN exchange failed.

{On another host PC (this runs a different version of bluez), when I edited the "hcid.conf" file to enter a different device class, and later when I ran "hciconfig -a", after running "hcid -f /etc/bluetooth/hcid.conf", I could see this device class modification reflected}

Any suggestions ?
Am I missing something ?

Ebin Jose.

All times are GMT -5. The time now is 06:21 PM.