-   Linux - Wireless Networking (
-   -   blacklisting bcm43xx (

crashsystems 10-28-2006 07:57 PM

blacklisting bcm43xx
I have an Acer Aspire 3000 with the bcm4318 network card. When I started off with this computer, I was using ndiswrapper in Ubuntu 6.06, and have set up this config using the directions at several times without a problem. However, today I decided to to a new install on my system (had nothing better to do) with the shiny new Ubuntu 6.10. Once I had the new version on my box, I used the same set of instructions to get wireless working, but to no avail. When I run the following two lines

modprobe -l | grep bcm43xx
modprobe -l | grep ndiswrapper

I see that both are loaded, though the line I added to /etc/modprobe.d/blacklist should of taken care of bcm43xx. The only thing I can think of with this is that 6.10 switched from init to upstart, so perhaps that has someting to do with that. Also, when I tried rmmod on bcm43xx, I got the following

crashsystems@crashsystems:~$ sudo rmmod bcm43xx
ERROR: Module bcm43xx does not exist in /proc/modules

So I am at a complete loss as to how to get this to work. Does anyone have any sugestions on how I can successfully blacklist or remove the bcm43xx module from my system, or any other way to get ndiswrapper to work with 6.10? Your help will be greatly appreciated.


BCarey 10-28-2006 10:03 PM


modprobe -l
lists all modules on your system, regardless of whether or not they are loaded.

lists all the loaded modules.

lsmod | grep bcm43xx
will probably show that it is not loaded, since you cannot rmmod it.


crashsystems 10-29-2006 12:02 PM

Well, I guess that my blacklisting of bcm43xx worked, because when I use lsmod to search for it, I see that it is not loaded. However, ndiswrapper is not loaded ether. So I tried using the modprobe command to load it manually, and it didn't work. After it failed to load, I got some error stuff in /var/log/syslog. Here is the output from my shell session:

crashsystems@crashsystems:~$ sudo modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.17-10-generic/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Invalid argument
crashsystems@crashsystems:~$ tail /var/log/syslog
Oct 29 11:53:07 crashsystems kernel: [17180165.968000] ndiswrapper version 1.22 loaded (preempt=no,smp=yes)
Oct 29 11:53:07 crashsystems kernel: [17180165.972000] ndiswrapper (wrapper_init:129): loadndiswrapper failed (32512); check system log for messages from 'loadndisdriver'
Oct 29 11:53:07 crashsystems kernel: [17180165.972000] ndiswrapper (wrapper_init:136): ndiswrapper: initialization failed

Does this give anyone an idea about why ndiswrapper won't load?


crashsystems 10-29-2006 12:52 PM

I just figured out how to fix the problem. I found the solution on post number 4 of an thread. BCarey, thanks for your help.


All times are GMT -5. The time now is 09:35 PM.