-   Linux - Wireless Networking (
-   -   Best Tool for Wireless Management in Mandrake 10.1 (

deepfrybonanza 02-17-2005 10:38 PM

Best Tool for Wireless Management in Mandrake 10.1
My Wifi worked perfectly from install with Mandrake 10.1 on my home network (I'm using it right now), but I can't seem to get the settings to work with the wireless network at school, which requires a WEP key. I've been right-clicking on the network icon in the bottom-right menu and using that to change the settings, but either they're not sticking or they're not working correctly. I've read about other tools for confirguring wireless, but I can't find/use kwifimanager and drakroam just gives me a bunch of error messages. Is there any kind of graphical tool I can use to mess around with my settings until I find one that sticks? Are there any special tricks for connecting to secure networks?

snecklifter 02-18-2005 04:42 AM

Its good to learn command line instructions in linux as these frequently give better error/debugging messages as well as removing an additional application layer to the whole process of eradicating the problem. Basically its a three step process to connecting to a WEP-enabled network.
1. Set the key
2. set the ssid
3. get/set an IP address

deepfrybonanza 02-18-2005 01:50 PM

Okay, I've got the first two down according to iwconfig, but shouldn't dhcpcd accomplish the third? For some reason or another it doesn't work... though dhcpcd doesn't return any errors.

snecklifter 02-18-2005 01:59 PM

Not necessarily. I use the alternate command
dhclient eth1
to get my IP address. Your interface may be wlan0 or whatever in ehich case replace the eth1.

deepfrybonanza 02-18-2005 03:37 PM

Still no dice... it says "No DHCPOFFERS received. No working leases in persistent database - sleeping." Any ideas what the problem might be? Back when I had windows on this laptop it connected with no problem at all. iwconfig says I have the WEP key and ESSID configured properly and that's supposedly the only two things I need to connect to this network.

snecklifter 02-18-2005 04:00 PM

Then I'd try disabling WEP on your WLAN altogether, re-try connecting and if this works you know its a WEP issue.

deepfrybonanza 02-18-2005 09:00 PM

Unfortunately, that's not an option as it's my college's network.

All times are GMT -5. The time now is 11:36 PM.