-   Linux - Wireless Networking (
-   -   Belkin F5D7010 (

jr206 12-14-2004 01:52 PM

Belkin F5D7010
Hi all. I am messing around with Damn Small Linux ( on an IBM Stinkpad 390x. Now my dilemma lies when I try to set up my Belkin F5D7010 PCMCIA card with ndiswrapper. I use ndiswrapper from the command prompt (as root of course) to install the drivers all works fine when I do the ndiswrapper -l to check if its there it show that the hardware is there, so far so good now from there I try to do modprobe ndiswrapper it starts to do its thing and SUCESS the light comes on! But wait my whole OS freezes!! Now I have tried this several times and what happens is that sometimes it freezes and when it does not freeze it does not give me my wlan0 that I need to finish configuring my card. I also tried to configure using Ndiswrapper from the gui that DSL provides me with but when I redirect Ndiswrapper to the correct drivers it does the same thing! Another thing I read (I think it was on an Ndiswrapper FAQ) was that that occurs when you have ACPI enabled in the kernel? Which causes IRQ conflict or something like that, I will do research on that in a bit. I also posted a thread on the DSL forum but no replies there :-/. As always any suggestions and ideas are welcome.

Thank you

bbo 03-04-2005 06:42 PM

Check the what .sys file you are using.
That kind of problem occurs when you load the wrong .sys file for the chipset of your card.
Get the correct .sys file from your chipset manufacturer website.
check this link

You may need to find out what chipset is used in your card.

copy the correct .sys file into /etc/ndiswrapper/your_card_name_folder

hope this help


linux23rookie 04-19-2005 08:56 AM

Belkin F5D7010 version (3) or 3000 pcmcia card on Sony PCG-FX340 Laptop
I don't have any questions or anything. I just want to post this as many places as possible because I couldn't find someone else with this card and also, I remember seeing that it wasn't supposed to work with Linux.

Suse 9.1 Pro, works with NDISwrapper.
Belkin F5D7010 version 3000 or 3 using the A-link driver. Actually I used the driver from the CD by using Wine to extract the files and then, finding the .INF file and putting it where I desired. This works although it says that it's fuzzy.

I followed the instruction on the following site except for the removal of the *.o files.

All times are GMT -5. The time now is 12:34 AM.