-   Linux - Wireless Networking (
-   -   Belkin F5D6051 USB Wireless Help (

EwanG 10-17-2004 10:13 PM

Belkin F5D6051 USB Wireless Help
Have picked up one of these Belkin USB key form factor Wireless 802.11b devices. Reading around, it seems like one of the similar devices uses an Atmel radio. However, trying the Atmel driver hasn't worked.

So I then tried using the NDISwrapper tool that comes with Knoppix when you install it to HD (using the 2.4.27 kernel), but it doesn't seem to be able to run the driver either. It installs the .inf file, but then says it can't find the device.

Anyone know what I'm missing, and how to fix it?


EwanG 10-18-2004 07:43 PM

At this point I'd be happy if someone could even help me figure out what radio chipset the Belkin F5D6051 uses, I'd be a happy camper. Having done all the Atmel stuff, the fact that it's still not coming up makes me a bit suspicious that it might not be based on the Atmel after all.

I assume that Belkin has to do some kind of FCC registration or something?


darkleaf 10-19-2004 03:39 AM

IIRC someone found that info with "lsusb" Couldn't say for sure cause I don't have that installed.

snecklifter 10-19-2004 05:32 AM

Hey Ewan,

Check out

as it looks as though you need a kernel patch of some kind. Also possibly a firmware update may be in order.
Hope this helps

This was found at the HCL at

EwanG 10-19-2004 06:09 AM

Well, sounds like I at least have some things I can try now. Will let y'all know if I get it working.


EwanG 10-21-2004 09:19 AM

A bit of an update. The kind folks who develop the Atmel Driver at were able to help me determine that the Belkin F5D6051 actually uses the Zydas 1201 chip rather than the Atmel one.

Looking at the homepage for the driver for this chip (, it appears that it might be possible to use the latest wlan-ng driver to run this, though I'm not clear whether I'm reading the information correctly or not.

As such, if you run a Debian distro, and have managed to get a device using this chip to run (preferably the Belkin), I'd love to hear how you did it. Of course I'd also be interested in knowing whether you are using a 2.4 or 2.6 kernel to determine which I want to use for this.

Thanks in advance.

EwanG 10-26-2004 05:42 PM

For posterity or anyone else dealing with this in the future:

Begin by making sure the device is unplugged, and leave it unplugged until directed below
1) Goto
2) Use CVS to get the most recent copy of the ZD1201 driver (not the wlan-ng that is on the main DL)
3) Get a 2.9 kernel
4) Patch the 2.9 kernel using the 2.8.1 diff file from the ZD1201 driver directory
5) Build the kernel
6) Deploy the kernel
7) Reboot
8) Go to the directory with the ZD1201 driver
9) If you are using the Belkin, make sure that the zd1201.c file has a USB ID for the Belkin (latest one is supposed to)
10) run "make"
11) run "make install"
12) copy the zd1201.fw file to the directory your distribution uses for hotplug (/usr/lib/hotplug/firmware in many cases)
13) Reboot
14) Plug in the device
15) dmesg should show it was recognized and loaded
16) iwconfig and such to get things going


snecklifter 10-27-2004 05:01 AM

hey Ewan,

If you feel like it you can add to the HCL which I'm sure would be appreciated.


EwanG 10-27-2004 10:47 AM


arenputt 12-07-2005 07:56 PM

*blank stare*
Ok, I did some reading and it sounds like you have the best resolution, but could you dumb it down for me? Im a first time user with Fedora 4. I dont know how to patch a kernal or pretty much anything else. Im not even sure what files to get off of sourceforge. Can anybody translate the above steps, or point me off in a direction to do it myself?

All times are GMT -5. The time now is 04:57 PM.