LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 11-26-2011, 12:17 AM   #16
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20

Thanks for your help and friendliness. Your help is greatly appreciated. Although, the quoted wiki is for Lenny, I can adapt what is written to Squeeze and get my wifi working.

Most appreciated,
Edward.
 
Old 11-26-2011, 07:40 AM   #17
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
You're welcome, glad to be of service. If this doesn't solve your issue there are still other options we can explore and try.

Good luck. ;-)
 
Old 11-26-2011, 01:46 PM   #18
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
I run the command:
Code:
# usermod -a -G netdev username
but, unfortunately, I am still incapable to connect. I tried to issue the command:
Code:
ping -c 1 www.google.com
as a normal user and as root failing on both occasions.

My username was also successfully added to the netdev group as you can see below:
Code:
$ groups
edbarx cdrom floppy audio dip video plugdev netdev
 
Old 11-26-2011, 07:20 PM   #19
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Have you rebooted since you added your user to netdev? If so, we've eliminated that possible problem so let's have a look at some other possible causes. Please post the results of the following.

Code:
$ cat /etc/network/interfaces
$ cat /etc/NetworkManager/NetworkManager.conf
# lsmod  | grep "b43\|ssb\|bcma\|wl"
Good luck. ;-)
 
Old 11-27-2011, 01:26 AM   #20
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
Yes, I rebooted, but the problem is still boldly manifesting itself.

Code:
$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
Code:
$ cat /etc/NetworkManager/NetworkManager.conf
[main]                                                                           
plugins=ifupdown,keyfile                                                         

[ifupdown]
managed=false
Code:
# lsmod  | grep "b43\|ssb\|bcma\|wl"
wl                   1937423  0 
lib80211                2870  2 lib80211_crypt_tkip,wl
EDIT:

Code:
root@edbarx-pc2:/home/edbarx# iwconfig -v
iwconfig  Wireless-Tools version 30
          Compatible with Wireless Extension v11 to v22.

Kernel    Currently compiled with Wireless Extension v22.

eth1      Recommend Wireless Extension v19 or later,
          Currently compiled with Wireless Extension v22.

EDIT 2:

Running knetworkmanager from a terminal as a normal unpriveleged user, issues these messages. I think, the problem has to do with a missing parameter that should be passed to a CLI backend program.
Code:
edbarx@edbarx-pc2:~$ knetworkmanager
knetworkmanager(2562)/kdeui (Wallet): The kwalletd service has been disabled 
knetworkmanager(2562)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_networkmanager07.so" does not offer a qt_plugin_instance function.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)

QLayout: Attempting to add QLayout "" to InterfaceConnectionItem "", which already has a layout
edbarx@edbarx-pc2:~$ Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
The last three lines were printed to the screen when I used the systray applet to connect i.e. by selecting its Enable Wireless menu.

Thanks.

EDIT 3:
I enabled the kde4 wallet service and starting knetworkmanager from a terminal as a normal user responded with:
Code:
$ knetworkmanager
knetworkmanager(2526)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_networkmanager07.so" does not offer a qt_plugin_instance function.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
However, I am still unable to connect.

Last edited by edbarx; 11-27-2011 at 03:09 AM. Reason: To post more information.
 
Old 11-27-2011, 07:14 AM   #21
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
I'm reading from here.

http://wiki.debian.org/NetworkManage...ger_in_Squeeze

It looks like you need to set

Code:
[main]                                                                           
plugins=ifupdown,keyfile                                                         

[ifupdown]
managed=true
in /etc/NetworkManager/NetworkManager.conf.

Googling the error also suggests this may help. Issue the following.

Code:
# /etc/rc.d/networkmanager stop
# rm /var/lib/NetworkManager/NetworkManager.state
# /etc/rc.d/networkmanager start
Good luck. ;-)

Last edited by Peacedog; 11-27-2011 at 07:21 AM.
 
Old 11-27-2011, 02:40 PM   #22
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
I edited the file /etc/NetworkManager/NetworkManager.conf setting managed to true. The systray applet instead of saying "unmanaged", is reporting "unavailable". As soon as I have the opportunity I will do the final test: I am positively expecting it to work as it is clear we are on the right track.

I will inform you of my success.

EDIT:

I tried but for some weird reason I couldn't establish a connection with the router even though the latter is designed to support Linux.

At this point, I am truly dry of ideas. Any suggestions are most welcome.

Last edited by edbarx; 11-28-2011 at 03:14 PM. Reason: To append more information.
 
Old 11-28-2011, 07:00 PM   #23
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Did you remove the NetworkManager.state file and restart the network services?

Good luck. ;-)
 
Old 11-30-2011, 12:04 AM   #24
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
I am testing my laptop's wifi configuration at someone else's home because at the moment I haven't purchased a wifi router. This to make sure I don't purchase anything that wouldn't work under Linux. I think, the configuration is sane, but the password may not be, so I will have to take the laptop to a place where wifi is installed for the general use of the public. Usually, these places are town squares, public garders, etc.
 
Old 11-30-2011, 09:42 PM   #25
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
If you're considering the router don't hesitate based on compatibility. Routers are generic, any device with any OS that has a working wireless card/radio should connect. The only requirement is a working wifi card/radio in the pc, laptop, phone, tablet, etc. and the proper security level of the device to match the security level of the router.

Good luck. ;-)
 
Old 12-02-2011, 04:06 PM   #26
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
Thanks for your advice. I already had the intuition that wifis should be compatible with Linux.

I think, that a WIFI's range should match the one of the pc's wireless network adaptor: as I see it, it is useless to use a longer range WIFI router if the pcs connected to it don't have as much range as the router. What do you think?
 
Old 12-05-2011, 08:12 PM   #27
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
If you're referring to the wireless standard as in B,G, or N, then yes your adapter needs to be compatible, but most devices and routers are backward compatible. That is, if the router is capable of the wireless N standard it should also be able to accept G or even B clients. Hope that makes sense.

Good luck. ;-)
 
Old 12-06-2011, 06:13 AM   #28
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
I purchased a TP-Link wireless router today but couldn't connect to it although Windows 7 had no problems whatsoever. I placed the router about 1 metre away from the laptop to make sure there is a good signal during the configuration. I cannot even display its configuration page or ping it although I am using the IP shown on its package. This is rendering me nuts!

EDIT:
I used the file /etc/network/interfaces and manually configured eth1 which happens to be the wireless chipset. The solution worked but I need to tweak it a little more so that dhcp doesn't unnecessarily slow my booting process.

I configure eth1 in this way (the password and SSID omitted):
Code:
# wireless configuration
auto eth1
iface eth1 inet dhcp
#   wpa-driver wext
   wpa-ssid omitted
   wpa-ap-scan 1
   wpa-proto WPA RSN
   wpa-pairwise CCMP
   wpa-group CCMP
   wpa-key-mgmt WPA-PSK
   wpa-psk "omitted"
Do you know what I should do to instruct dhcp not to slow my booting process in case the router is unavailable?

Thanks.

EDIT 2:
I found that omitting the line "auto eth1" stops dhclient from requesting an IP address making the booting process proceed without unnecessary delay. However, I couldn't connect to the internet when kde loaded. I had to become root and issue the command:
Code:
ifup eth1
I there anything besides network-manager (network-manager is failing) that can take care of initialising eth1 whenever necessary?

OR better still, do you know of a better solution?

Last edited by edbarx; 12-06-2011 at 04:02 PM. Reason: To update the information.
 
Old 12-06-2011, 08:30 PM   #29
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
There must be an underlying cause to Network-Manager failing which may also plague any other "Wifi Managers". That said, I prefer WICD or even Wifi Radar, but Network-Manager has more available options...when it's working properly.

Good luck. ;-)
 
Old 12-07-2011, 05:12 AM   #30
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 20
wicd crashed as soon as the system tried to start it, so I had to remove it. I installed wifi-radar to check what it can offer: it seems my best option is to either:
a) manually start the wifi networking
b) configure /etc/network/interfaces manually to bind an IP without the use of dhcp.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01) f14 on dell laptop navets Fedora 5 05-16-2011 04:17 AM
wifi networks not visible thru Broadcom BCM43225 802.11b/g/n on Acer 5745G mithuns Linux - Wireless Networking 3 12-12-2010 08:11 PM
Intel 4965 AGN - can't connect to wireless 802.11b router, can connect to 11g siodine Linux - Wireless Networking 3 12-01-2007 07:36 AM
ipw2100 on Sony Vaio TR2AP (Rev 04 802.11b Intel 2100) Problems Cabe24 Linux - Laptop and Netbook 1 02-05-2006 11:46 AM
How to connect to internet using the internal 802.11b/g wireless LAN in laptop bin75 Linux - Wireless Networking 1 04-21-2005 09:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration