-   Linux - Wireless Networking (
-   -   bcm4311 rev 2 wireless on opensuse 10.3 (

bahbahthelamb 12-15-2007 04:59 PM

bcm4311 rev 2 wireless on opensuse 10.3
It is a Compaq Persario F572 with a bcm4311 Rev 2 wireless on a openSUSE 10.3 system. This is supposed to be an x-mas gift for someone and I've been getting it configured in short moments while she's not home. Getting the wireless working is a serious pain. I've gotten broadcom based wireless working before on linux using ndiswrapper, but in this instance, I can't get it working with neither bcm43xx nor ndiswrapper.

I tried using the bcm43xx-fwcutter app, and afterwards, the light does turn blue telling me wireless radio is on, but I still see nothing when I scan, and can't get a dhcp lease when I connect (with neither knetworkmanager nor ifup).

After having an issue with bcm43xx driver, I ran a rmmod to get rid of the bcm43xx driver and tried to get it up with ndiswrapper. When I run ndiswrapper -l it shows driver installed properly, then I run a ndiswrapper -m and a modprobe ndiswrapper to add it in. It shows ndiswrapper in dmesg, but it doesn't show a wlan0 registered like it should.

To make matters worse, I re-installed the OS to start fresh, and before I could boot into it with adding the noacpi and nolacpi options on /boot/grub/menu.lst, now adding it or not, it won't boot into X unless I go into failsafe and run init 5. I'm getting frustrated because I'm about to have to hide the computer in the closet again, and I have made no progress, just made it worse.

It has been a while since I've had to configure wireless on a linux box, so I'm probably just forgeting a step, but every guide I've already looked at online doesn't show anything that I didn't already try.


sklitzz 12-19-2007 03:49 AM

I have ubuntu and had a whole lot problems with Broadcom. This helped me after trying almost everything not sure if it will help you.

bahbahthelamb 01-07-2008 10:22 AM

Thanks for your help
Much appreciated, I will try a openSUSE equivelent to what is in that article with my other broadcom adapter, for I ended up selling that laptop (with Windows back on it, yuck!), and will be getting a different laptop soon enough.


All times are GMT -5. The time now is 06:02 PM.