-   Linux - Wireless Networking (
-   -   Backtrack 5 r3 Trouble connecting to the internet with TP-link TL-WN722N USB card. (

TomGauss 03-02-2013 09:23 PM

Backtrack 5 r3 Trouble connecting to the internet with TP-link TL-WN722N USB card.
Hi, I am new to this forum and to linux, so if I post with bad etiquette or anything, I apologize.

Alright, here is my problem. I am running Backtrack 5 r3 installed on my hdd (not partitioned; this hard drive only has BT on it) with a TP-link TL-WN722N USB wireless card. I know that Backtrack detects my device because it shows up as 'Atheros AR9271' when I run lsusb. However, when I open wicd, it shows that there are no networks available, and when I run iwconfig I get:

lo no wireless extensions.
eth0 no wireless extensions.

When I run airmon-ng I get:

Interface Chipset Driver

but it doesn't show anything else. I have the AR9271 driver. Also, my wireless config file is empty. I am pretty sure that is part of the problem, but I think there may be more to it as well. Any help is greatly appreciated. Thanks!

John VV 03-06-2013 10:53 PM

Please add that this is BackTrack 5r3 in the title

and add that this is
A full install to the hdd
a usb install , live or persistent. If persistent is it encrypted or not .
if this is a VM install

other than
read the bt documents i will not comment more on this .

TomGauss 03-07-2013 09:31 AM

Thanks for the input, and I apologize for leaving out that information. I've been combing over the forums here and on the backtrack forums, but I still haven't found anything that works.

TomGauss 03-11-2013 11:32 PM

Alright, so I learned that my problem may be that I needed to either install some drivers that I already had, or get some drivers that I didn't have an then install them. So I got the compat wireless drivers from here:
and ran


tar -xf /root/compat-drivers-3.9-rc2-2-su.tar.bz2
cd compat-drivers-3.9-rc2-2-su
make install
make unload

which ran through all of the install info. Then I ran a modprobe for two of the ath9k drivers


modprobe ath9k_htc
modprobe ath9k

but nothing happened. I don't know if this is whats supposed to happen if everything is running smoothly or not.
Then I rebooted, and ran service networking start, and service wicd start, but when I opened wicd there were no connections available.
and when I run airmon-ng it still doesn't recognize my device. It just gives the same output I posted above when I ran it before.

What am I doing wrong?

All times are GMT -5. The time now is 07:34 PM.