-   Linux - Wireless Networking (
-   -   Atheros sees network but will not connect (

Moomtaz 10-29-2008 05:25 PM

Atheros sees network but will not connect
I have been trying to go all Linux for a while but the only thing really holding me back is my wireless connection. I have tried both methods madwifi and ndiswrapper and both have failed. I have gotten further with ndiswrapper it sees the wifi card and tries to connect but it never succeeds. It gets to 28% and then stalls until dead. Here are my settings.

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ndiswrapper -l
net5211 : driver installed
device (168C:001C) present (alternate driver: ath_pci)

This is the last little leg of my linux exodus. Then I can tinker with the other things that I may find irritating like web fonts but mostly everything else I am ok with. I followed this tutorial to a T to get as far as I am.

Can't post that site yet

Any help would be great.

Quakeboy02 10-29-2008 06:09 PM

Well, you have it almost there. It's been awhile since I connected without wpa_supplicant, but I believe you can just issue one of the following commands, depending on which dhcp client you have:

dhclient3 wlan0
dhcpcpd wlan0

If you want to do it all manually, I think you can do just either of the following

ifconfig wlan0 up
ifconfig wlan0 <ip address>

If you want to use wpa_supplicant for WPA-PSK security, let me know.

PTrenholme 10-29-2008 06:33 PM

Might one ask which distribution you're using, and which processor? :scratch: If you're using a 64bit processor, the ath5k and ath9k drivers may fail for the older Atheros 5008EG chips.

Note also that having multiple wireless drivers installed will almost always cause all of them to fail. Since you're getting some response, that's unlikely to be your problem. Still, it might be worth checking in the dmesg output for mentions of Atheros or ath.

Does your distribution automatically install the NetworkManager application? If so, and if you're using GNOME or KDE as your desktop, look for the network manager applet's icon in the system tray. Clicking on the icon should display a list of access points upon which you can click to connect. (The initial click can be either a left or right click depending on you distribution packager's choice, so, if one doesn't work, try the other. One shows the list, the other shows network options.)

Moomtaz 11-13-2008 03:46 PM

Holy crap I logged in today and it came up just like that. I didn't do anything it just worked. I will have to try to log in and out now so I can see if it is something with me or something. I didn't change anything. It just worked.

Moomtaz 11-13-2008 03:46 PM

Oh and it is so much quicker than VISTA Sooooo Much quicker.

Moomtaz 11-14-2008 07:05 PM

Finally fixed it
Ok I was close the other day when I logged on and had Internet. then of course I had to log off and when I came back on I was in the same predicament as before. Seeing the network but no juice. 28% is all that she would do before defaulting back to the wireless control screen asking for my WEP. Well I was adamant that this time I was going to make the switch. I checked out this thread ( and it got me to reinstall kubuntu version 8.10 and then do the madwifi thing and shazaaam that did it. This is awesome, I can compute in peace without my harddrive spinning like someone is going to cut off its head. My harddrive never stops spinning in Vista. I think I will take it easy for a minute though. I'm not going to go crazy and install everything under the sun. But as long as I can do the basic stuff. I should be just fine. I hope this helps everyone else.

All times are GMT -5. The time now is 08:41 AM.