-   Linux - Wireless Networking (
-   -   Atheros AR9285 and OpenSuse 11.4. What's the matter? (

aal 10-09-2011 07:47 PM

Atheros AR9285 and OpenSuse 11.4. What's the matter?
Hi all,

My Atheros AR 9285 wireless LAN worked with ubuntu 11.04, but not with Opensuse 11.4.

Googling about, apparently this card was fine with Opensuse 11.2 (and I saw it present on 11.3 before upgrading to 11.4). I found several other users at another forum also finding it had become non-operational after upgrading to OpenSuse 11.4. Wireless functions not enabled at all.

One blog post suggested it was a problem with a software switch that is blocking access to it? I ran


rfkill list all

as recommended to show if the software block was on (and it is), so then ran

rfkill unblock all

I believe I saw the card come up briefly but could not confirm for sure, or repeat later (after failing to connect/configure).

Does anyone one know what the story is on this? And how to get the card up on 11.4. It is not even clear to me if this has to be done on Knetwork manager or with YAST?

I'm using KDE 4 desktop and the laptop is a dell inspiron 14R, core i3

Thanks in advance.


aal 10-11-2011 10:22 PM

Dear all,

This is fixed now. The main remaining problem was KNetworkManager applet not showing. Fixed by either (I'm not sure which) 1. drag KNetworkManager icon from start bar to ~/kde4/autostart and create link or 2. edit file root/var/lib/NetworkManager/NetworkManager.state to set network and wireless to true. Possibly combined with rfkill as above.


All times are GMT -5. The time now is 04:47 PM.