-   Linux - Wireless Networking (
-   -   About to Give up on Mint Wireless (

thund3rstruck 04-10-2011 07:05 PM

About to Give up on Mint Wireless
I'm absolutely certain that wireless was working when I first installed Mint 9 but I always use Ethernet. Took the laptop to the hospital tonight for my wife to use and like a total fool I couldn't get this machine to connect to the hospital's free wireless (making an already bad situation even worse for my wife).

I must assume that the card is recognized and functional since the amber indicator light is lit up and iwconfig returns legitimate output.


# iwconfig wlan0 scan
wlan0    Scan completed :
          Cell 01 - Address: 00:16:B6:D6:DE:6F
                    Frequency:2.437 GHz (Channel 6)
                    Quality=59/70  Signal level=-51 dBm 
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s

I went into the Gnome > Preferences > Network Connections applet and entered the SSID for the hospital SSID but nothing happened.

Checking for an IP address turned up nothing:


$ ifconfig wlan0
wlan0    Link encap:Ethernet  HWaddr 00:13:02:0a:57:39 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I've tried to release and renew using

# ifconfig wlan0 down
# ifconfig wlan0 up

With no results. As a last ditch effort I went back home to do a sanity check and I got the same results on my home wireless network (so maybe I'm crazy and I never connected to wireless from this machine). I had to dig up an old Windows XP laptop for my wife to use.

Anyways this is a built in Intel Pro Wireless card. I really have no idea what to try next. I'm so frustrated that I'm almost ready to wipe the machine and put Fedora on it.


# lspci | grep -i network
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

The Network Connections applet in gnome doesn't seem to work at all. I enter the SSID and click apply and nothing happens. I never get an IP address.

Peacedog 04-10-2011 08:17 PM

Hi thund3rstruck, Welcome to LQ. Please post the output from the following.


# lsmod | grep iwl3945
$ ls /etc/lib/firmware | grep .ucode

Good luck. ;-)

thund3rstruck 04-11-2011 07:59 AM

Thanks for the welcome! But I've been a member for 6 years ;) ... I just have no experience troubleshooting wireless :(

Sure thing...


$ lsmod | grep iwl3945
iwl3945                68727  0
iwlcore              105922  1 iwl3945
mac80211              204922  2 iwl3945,iwlcore
led_class              2864  3 iwl3945,iwlcore,acer_wmi
cfg80211              126485  3 iwl3945,iwlcore,mac80211


$ ls /lib/firmware | grep .ucode

It looks to me like the drivers are all loaded properly because the wifi light is amber and the interface is listed in ifconfig and I can use some utilities like iwlist just fine. I just have no applet in my taskbar and the Network Connections applet in the System settings doesn't do anything. I'm not able to get an ip address from any of the 3 wifi access points I've tried in the last 2 days. I'm fairly sure this worked when I first install Mint so I must have screwed something up somehow in the months since the installation.

Peacedog 04-11-2011 10:32 PM

Have you tried associating with an AP and issuing dhclient from the cli?


# iwconfig wlan0 essid youressid key yourkey
# dhclient wlan0

Good luck. ;-)

thund3rstruck 04-11-2011 10:46 PM


Originally Posted by Peacedog (Post 4321741)
Have you tried associating with an AP and issuing dhclient from the cli?


# iwconfig wlan0 essid youressid key yourkey
# dhclient wlan0

Good luck. ;-)

I do a lot of development and code compilation on this machine and I'm certain that I royally screwed the pooch. Ultimately I brought the laptop to the hospital and while my wife was sleeping I tarred up our home directories, upgraded to Mint 10, and restored our home directories. Mint 10 is working perfectly and I was needing an upgrade anyhow (my Mint 9 load was getting a bit dated).

I'm not usually the type to 're-install'... but this was really biting me and starting to wear down my ego. I had to get a resolution ASAP.

Thanks again PeaceDog for your patience, I'm gonna make a note of the iwconfig command you mentioned (I played with iwconfig but wasn't getting the syntax right because stdout kept displaying the help screen) just in case I should come across this in the future.

Peacedog 04-12-2011 09:50 PM

Glad you got it sorted!

Good luck. ;-)

All times are GMT -5. The time now is 11:25 PM.