LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 12-30-2003, 08:15 AM   #1
wernerholt
LQ Newbie
 
Registered: Dec 2003
Posts: 2

Rep: Reputation: 0
3com 3crshpw796 with admtek 8211 chip


Hello,
I have an new Wirelesscard for my Laptop. Its an 3Com Cardbus-Card 3CRSHPW796 with an ADM8211-Chip on it. Under Windows its working well, but under Linux it isnt!
I have an 2.4.23er kernel compiled with gcc 3.2 what i have installed under debians current stable distri woody.

First i tried the driver from 3com-site. It is an modified version 1.03 from admteks driver. but this is not compiling without error. Why?
It tells "unused struct content"

Second I got the driver 1.05 from the admtek-site ht_tp_ww_w.admtek.com.tw/download/nic/adm8211/ADM8211_src_105.tar.gz. This I modified like ht_tp_ww_w.espina.info/papers/officeconnect/ (the vendor-ids).
It is compiling without errors!But i can't get any connection to my accesspoint. This isnt working with and without wep-encryption. Sometimes if i'm switching to ad-hoc-mode and then back to managed-mode i get the correct MAC-Address of my Accesspoint but no connection. I know, that the last iwconfig command has to set the essid to get the former commands into the card.

I have also installed the new wireless-tools 26, but nothing.

What could be wrong? How can I get this working? I have to get this working but some weeks of googling and testing something didnt help.

Thank you for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SMC2602W (ADMTek 8211) problems donniejones18 Linux - Wireless Networking 0 02-08-2004 11:37 AM
ADMtek 8211 in Mandrake 9.2? isdnip Linux - Wireless Networking 34 01-24-2004 07:33 AM
ADMTek 8211 - iwconfig won't save settings daz0r Linux - Wireless Networking 11 01-01-2004 02:18 PM
3crshpw796 on linux with cardbus and selfcompiled 8211.o wernerholt Linux - Hardware 0 12-30-2003 06:46 AM
HELP!! ADMTek 8211 and Red Hat 9.0 Crawfy Linux - Networking 0 08-12-2003 04:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration